AAA, NAC, Guest Access & BYOD

Unable to add MSSQL DB as auth source when Integrated authentication is enabled.

Aruba Employee

Environment Information- Tested on CP 6.3.x and 6.4.x.

Symptoms

I am getting the below error when I try to configure the authentication source.
"Primary: Login Username contains special characters other than -, _ and ."    

 

 

Cause- Connecting to MSSQL DB using integrated authentication needs the login username with domain prefix or userPrincipleName(UPN). But the currently available ClearPass versions will not allow you to enter any special characters other than "-,_ and ." in the login username filed when you add the MSSQL DB.

 

Resolution- The SQL authentication source username validator in ClearPass 6.5.0 release is adjusted to accept the domain prefix with the login username field. So that the MSSQL DB enabled with integration authentication can be configured as authentication source from ClearPass 6.5.x.

 

Answer- The domain prefix can be added in the format DOMAIN\\Username.

Note: Only username with domain prefix is allowed and  userPrincipleName(UPN) format is not support.

Please refer the below screen capture for configuration assistance.

rtaImage (2).png

 

 

Version history
Revision #:
1 of 1
Last update:
‎04-05-2015 02:55 AM
Updated by:
 
Labels (1)
Contributors
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: 
Is this a frequent problem?

Request an official Aruba knowledge base article to be written by our experts.