AAA, NAC, Guest Access & BYOD

What to do when we get ssl_error_bad_mac_alert on Firefox

Aruba Employee
Problem:

What can we do when we get "ssl_error_bad_mac_alert" while accessing clearpass using Firefox



Diagnostics:

When we try to access Clearpass using Firefox(version 28) we can see the below error message.

User-added image

 

Cause:

Issues reported caused by Firefox using some specific cipher suites that aren't supported properly by the server.

 



Solution

We can follow the below steps for resolving this issue.

  • In the Firefox browser’s address field, type “about:config”

User-added image.

 

  • Click on “I’ll be careful, I promise”
  • Search for ‘security.ssl3.dhe_rsa_des_ede3_sha’ 
  • This will be set to ‘true’ in the fourth column 
  • Change the value to ‘false’ by double clicking on fourth column 
  • Reload the browser.

 

Version history
Revision #:
2 of 2
Last update:
‎05-20-2016 04:10 AM
Updated by:
 
Labels (1)
Contributors
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: 
Is this a frequent problem?

Request an official Aruba knowledge base article to be written by our experts.