Access Points

Reply
Contributor II
Posts: 64
Registered: ‎09-17-2011

ipad - expected DHCP assign time

Hi guys
Just a quick one...what would you expect to be the "rough" time for an ipad to come out of sleep (eg user walks into office area and unlocks screen) to time DHCP is assigned (on a known remembered network) and IP is assigned and away surfing.

Reason I ask is we are seeing significantly different times with ipads vs other laptops...in the range of 45 seconds to a minute.

DHCP is assigned via the controllers - AP61 are the access points and 3400 controllers are the main units.

Anyone got any gut feel or experience or something similar...just that with these ipads there is so little you can on the actual devcice to troubleshoot....
Wally
Guru Elite
Posts: 20,568
Registered: ‎03-29-2007

Re: ipad - expected DHCP assign time

configure logging on your controller and watch that ipad when it comes out of sleep to see what is happening:

config t
logging level debugging user-debug
show log user-debug 50



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Contributor II
Posts: 64
Registered: ‎09-17-2011

Re: ipad - expected DHCP assign time

Hi there
ran the debug on the itouch and this is what I see

First I turn the wireless on the touch off and I get

Oct 12 14:56:49 :501102: |stm| Disassoc from sta: 58:55:ca:66:a9:a7: AP 10.1.128.207-00:24:6c:24:48:b1-EBT_N_Test Reason STA has left and is disassocisted
Oct 12 14:56:49 :501065: |stm| Sending STA 58:55:ca:66:a9:a7 message to Auth and Mobility Unicast Encr Open Multicast Encr Open VLAN 0xc8
Oct 12 14:56:49 :500511: |mobileip| Station 58:55:ca:66:a9:a7, 0.0.0.0: Received disassociation on ESSID: TTSGUS Mobility service ON, HA Discovery on Association Off, Fastroaming Enable, AP: Name EBT_N_Test Group TTSWLSW01 BSSID 00:24:6c:24:48:b1, phy g, VLAN 200
Oct 12 14:56:49 :522036: |authmgr| MAC=58:55:ca:66:a9:a7 Station DN: BSSID=00:24:6c:24:48:b1 ESSID=TTSGUS VLAN=200 AP-name=EBT_N_Test
Oct 12 14:56:49 :522004: |authmgr| MAC=58:55:ca:66:a9:a7 ingress 0x10ce (tunnel 78), u_encr 1, m_encr 1, slotport 0x1040
Oct 12 14:56:49 :522004: |authmgr| station free: bssid=00:24:6c:24:48:b1, valid=1, @=0x109db76c
Oct 12 14:57:11 :501106: |stm| Deauth to sta: 58:55:ca:66:a9:a7: Ageout AP 10.1.128.207-00:24:6c:24:48:b1-EBT_N_Test handle_sapcp
Oct 12 14:57:11 :501080: |stm| Deauth to sta: 58:55:ca:66:a9:a7: Ageout AP 10.1.128.207-00:24:6c:24:48:b1-EBT_N_Test Denied: AP Ageout


I then wait 30 seconds and turn the wireless on and get:


Oct 12 14:58:40 :501095: |stm| Assoc request @ 14:58:40.672990: 58:55:ca:66:a9:a7 (SN 3115): AP 10.1.128.207-00:24:6c:24:48:b1-EBT_N_Test
Oct 12 14:58:40 :501100: |stm| Assoc success @ 14:58:40.676052: 58:55:ca:66:a9:a7: AP 10.1.128.207-00:24:6c:24:48:b1-EBT_N_Test
Oct 12 14:58:40 :501065: |stm| Sending STA 58:55:ca:66:a9:a7 message to Auth and Mobility Unicast Encr Open Multicast Encr Open VLAN 0xc8
Oct 12 14:58:40 :522035: |authmgr| MAC=58:55:ca:66:a9:a7 Station UP: BSSID=00:24:6c:24:48:b1 ESSID=TTSGUS VLAN=200 AP-name=EBT_N_Test
Oct 12 14:58:40 :500511: |mobileip| Station 58:55:ca:66:a9:a7, 0.0.0.0: Received association on ESSID: TTSGUS Mobility service ON, HA Discovery on Association Off, Fastroaming Enable, AP: Name EBT_N_Test Group TTSWLSW01 BSSID 00:24:6c:24:48:b1, phy g, VLAN 200
Oct 12 14:58:40 :522004: |authmgr| MAC=58:55:ca:66:a9:a7 ingress 0x10ce (tunnel 78), u_encr 1, m_encr 1, slotport 0x1040
Oct 12 14:58:40 :522004: |authmgr| Deriving AAA profile from user attributes
Oct 12 14:58:40 :522004: |authmgr| missing AAA profile in wired profile
Oct 12 14:58:40 :522004: |authmgr| Error deriving default AAA profile
Oct 12 14:58:40 :522004: |authmgr| MAC=58:55:ca:66:a9:a7 def_vlan 200 derive vlan: 0 auth_type 0 auth_subtype 0

Now - here is the interesting bit (read problem!!) :mad:

At 14:58:40 - I see very briefly the wireless icon on the touch appear in line with the entry on the controller.

A few seconds later - the wireless bars on the touch disappear and then I lose wireless connectivity - BUT nothing changes in the logs.....the last entry is still 14:58:40.

Around 1 minute later the wireless bars come back and I can surf the web.
However there is no subsequent entry in the logs at all.

Any ideas?
Guru Elite
Posts: 20,568
Registered: ‎03-29-2007

Re: ipad - expected DHCP assign time

What version of code is this?


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Contributor II
Posts: 64
Registered: ‎09-17-2011

Re: ipad - expected DHCP assign time

Hi there,
Do you mean OS version? Version 3...
Wally
Guru Elite
Posts: 20,568
Registered: ‎03-29-2007

Re: ipad - expected DHCP assign time

Exactly what version? There is a bug that was fixed specifically for that issue.

The bug for that was fixed in the first shipping Version of ArubaOS 5.x, if you are planning to upgrade to ArubaOS 5.x, this will fix your issue.


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Search Airheads
Showing results for 
Search instead for 
Did you mean: