Aruba Instant & Cloud Wi-Fi

Reply
New Contributor
Posts: 3
Registered: ‎03-19-2016

Aruba 7005 controller - No DHCP assigned address through wired ports

Hi!

I have just received an ARUBA 7005 controller and I am first of all trying to test a basic setup without any APs connected through the wired ports. I am initially trying to configure an internal DHCP server to issue addresses through the wired controller ports.

 

The setup I am trying is as follows:

 

- Port 0/0/0 - VLAN 1, 192.168.178.10/24

- Port 0/0/1-0/0/3 VLAN 10, 10.0.0.1/24

 

In VLAN 10, I have configured an internal DHCP Server with the following params:

 

(Aruba7005) (config) # show ip dhcp database

DHCP enabled

# Test-DHCP-Pool
subnet 10.0.0.64 netmask 255.255.255.224 {
default-lease-time 86400;
max-lease-time 86400;
option domain-name "example.com";
option vendor-class-identifier "ArubaAP";
option vendor-encapsulated-options "192.168.178.10";
option domain-name-servers 10.0.0.1;
option routers 10.0.0.1;
range 10.0.0.65 10.0.0.94;
authoritative;
}

 

I do not get any IP address assigned via DHCP, just the auto-configuration assigned by the OS (169...).

 

I configured the DHCP logging on the controller and noticed the following errors relating to a DHCP relay server.

 

Mar 19 16:52:56 :202541: <DBUG> |dhcpdwrap| |dhcp| Received DHCP packet from Datpath, sos msg hdr flags 0x42 opcode 0x5a ingress 0x2102 vlan 10 egress 0xa src mac b4:b5:2f:35:0d:cc
Mar 19 16:52:56 :202534: <DBUG> |dhcpdwrap| |dhcp| Datapath vlan10: DISCOVER b4:b5:2f:35:0d:cc Transaction ID:0x420ba973 Options 3d:01b4b52f350dcc 0c:424f5944424f534333 3c:4d53465420352e30 37:010f03062c2e2f1f2179f92b
Mar 19 16:52:56 :202523: <DBUG> |dhcpdwrap| |dhcp| dhcprelay: dev=eth1, length=300, from_port=68, op=1, giaddr=0.0.0.0
Mar 19 16:52:56 :202532: <DBUG> |dhcpdwrap| |dhcp| got 0 relay servers

 

I am not very familiar with the details of DHCP but it looks to me that the controller is forwarding the DHCP request to a DHCP relay server and not trying to repond to the DHCP request itself.

 

Can someone help me to resolve the DHCP issue?

Guru Elite
Posts: 20,382
Registered: ‎03-29-2007

Re: Aruba 7005 controller - No DHCP assigned address through wired ports

1. Each VLAN interface must have an ip address, so that the DHCP sever knows what subnet is on each VLAN.

2.  You must assign each interface to a VLAN, so that DHCP knows what ip address range to give out.

 

config t

interface gigabitethernet 0/0/0

switchport access vlan 1

interface gigabitethernet

 

interface gigabitethernet 0/0/1

switchport access vlan 10

 

 

 

 

 

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

New Contributor
Posts: 3
Registered: ‎03-19-2016

Re: Aruba 7005 controller - No DHCP assigned address through wired ports

Thanks for the super fast response.

Here is how the interfaces and the VLANs are configured.

 

(Aruba7005) # show ip interface brief

Interface IP Address / IP Netmask Admin Protocol
vlan 1 192.168.178.10 / 255.255.255.0 up up
vlan 10 10.0.0.1 / 255.255.255.0 up up
loopback unassigned / unassigned up up

 

 

interface gigabitethernet 0/0/1
description "GE0/0/1"
trusted
trusted vlan 1-4094
ip access-group "allowall" session vlan 10
switchport access vlan 10
no spanning-tree
!

interface gigabitethernet 0/0/2
description "GE0/0/2"
trusted
trusted vlan 1-4094
ip access-group "allowall" session vlan 10
switchport access vlan 10
no spanning-tree
!

interface gigabitethernet 0/0/3
description "GE0/0/3"
trusted
trusted vlan 1-4094
ip access-group "allowall" session vlan 10
switchport access vlan 10
no spanning-tree
!

interface vlan 1
ip address 192.168.178.10 255.255.255.0
!

interface vlan 10
ip address 10.0.0.1 255.255.255.0
!

ip default-gateway 192.168.178.1
uplink disable

 

I am still getting the same behaviour in the DHCP log. See below.

 

Mar 19 17:52:20 :202541: <DBUG> |dhcpdwrap| |dhcp| Received DHCP packet from Datpath, sos msg hdr flags 0x42 opcode 0x5a ingress 0x2102 vlan 10 egress 0xa src mac b4:b5:2f:35:0d:cc
Mar 19 17:52:20 :202534: <DBUG> |dhcpdwrap| |dhcp| Datapath vlan10: DISCOVER b4:b5:2f:35:0d:cc Transaction ID:0xea6e9ce7 Options 3d:01b4b52f350dcc 0c:424f5944424f534333 3c:4d53465420352e30 37:010f03062c2e2f1f2179f92b
Mar 19 17:52:20 :202523: <DBUG> |dhcpdwrap| |dhcp| dhcprelay: dev=eth1, length=300, from_port=68, op=1, giaddr=0.0.0.0
Mar 19 17:52:20 :202532: <DBUG> |dhcpdwrap| |dhcp| got 0 relay servers

 

It seems that everything is configured as you suggested but it seems that the controller is still trying to relay the request rather than process the DHCP request itself.

 

Any other ideas?

Guru Elite
Posts: 20,382
Registered: ‎03-29-2007

Re: Aruba 7005 controller - No DHCP assigned address through wired ports

Your subnets and masks on your interfaces must match the subnets and masks on your Dhcp scope. You also do not need to put access lists on your interfaces: remove them.


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

New Contributor
Posts: 3
Registered: ‎03-19-2016

Re: Aruba 7005 controller - No DHCP assigned address through wired ports

Thanks a million for the great support. Problem solved


cjoseph wrote:
Your subnets and masks on your interfaces must match the subnets and masks on your Dhcp scope. You also do not need to put access lists on your interfaces: remove them.

 

Search Airheads
Showing results for 
Search instead for 
Did you mean: