Aruba Instant & Cloud Wi-Fi

Reply
Occasional Contributor II
Posts: 12
Registered: ‎09-03-2014

Aruba Instant IAP-2250-US with Cisco 3750X-48P-S

PROBLEM: I am trying to get LAG configuration setup on Cisco 3750 for Aruba Instant Access Point IAP-225-US. As I understand it the IAP-225-US has automatic LACP detection and should auto configure for LACP when connected to a switch that is setup for the LAG.

 

When I log into the IAP, and run the command show lacp status it is telling me that LACP Not Configured.

 

Cisco 3750X

 

interface GigabitEthernet1/0/8
 description Aruba_Ether0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 speed 1000
 duplex full
 channel-group 2 mode active
end

interface GigabitEthernet1/0/20
 description Aruba_Ether1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 speed 1000
 duplex full
 channel-group 2 mode active
end

interface Port-channel2
 description Aruba_Test_LAG
 switchport trunk encapsulation dot1q
 switchport mode trunk
end

 

 

ArubaIAP

 

wired-port-profile default_wired_port_profile
 switchport-mode trunk
 allowed-vlan all
 native-vlan 1
 shutdown
 access-rule-name default_wired_port_profile
 speed 1000
 duplex full
 no poe
 type employee
 auth-server InternalServer
 captive-portal disable
 no dot1x

 Cisco Status

 

show eth summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi1/0/9(P)  Gi1/0/10(P)
2      Po2(SD)         LACP      Gi1/0/8(I)  Gi1/0/20(I)

Before it setting it to fixed, it was saying status of SD, and the ports were in suspended.  

 

Aruba Status

show lacp status

LACP Not Configured


 



 

Moderator
Posts: 681
Registered: ‎04-16-2009

Re: Aruba Instant IAP-2250-US with Cisco 3750X-48P-S

Can you see if your Cisco switch has a command "no independent-state" for the LAG?

Occasional Contributor II
Posts: 12
Registered: ‎09-03-2014

Re: Aruba Instant IAP-2250-US with Cisco 3750X-48P-S

I came across this post, but pretty sure I did everything it suggested...

 

http://community.arubanetworks.com/t5/ArubaOS-and-Controllers/EtherChannel-between-Aruba-and-Cisco-switch/m-p/130611#M7083

 

Looking here...

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3750x_3560x/software/release/12-2_53_se/configuration/guide/3750xscg/swethchl.html

 

"

When you configure one end of an EtherChannel in either PAgP or LACP mode, the system negotiates with the other end of the channel to determine which ports should become active. If the remote port cannot negotiate an EtherChannel, the local port is put into an independent state and continues to carry data traffic as would any other single link. The port configuration does not change, but the port does not participate in the EtherChannel.

 

When you configure an EtherChannel in the on mode, no negotiations take place. The switch forces all compatible ports to become active in the EtherChannel. The other end of the channel (on the other switch) must also be configured in the on mode; otherwise, packet loss can occur.

"

 

I'll try channel-group mode on instead of active and do a reload of IAP to see if that fixes it.

Occasional Contributor II
Posts: 12
Registered: ‎09-03-2014

Re: Aruba Instant IAP-2250-US with Cisco 3750X-48P-S

Well, I think it's in a LAG, but not LACP....

 

(config-if)#int range gi1/0/8, gi1/0/20
(config-if-range)#no channel-group 2
(config-if-range)#channel-group 2 mode on
(config-if-range)#end
#show ether sum
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi1/0/9(P)  Gi1/0/10(P)
2      Po2(SU)          -        Gi1/0/8(P)  Gi1/0/20(P)

 Aruba Status

 

iap1# show lacp status

LACP Not Configured

 

 

Moderator
Posts: 681
Registered: ‎04-16-2009

Re: Aruba Instant IAP-2250-US with Cisco 3750X-48P-S

You do want mode active.    I did run into a similar issue using the Aruba MAS where LACP would not come up until I set "no independent-state".  Here is a snip of the Aruba config:

 

interface-profile lacp-profile <NAME>

   group-id 1

   mode active

   timeout short

   no independent-state

 

Once this was set LACP came up on the -225.

Occasional Contributor II
Posts: 12
Registered: ‎09-03-2014

Re: Aruba Instant IAP-2250-US with Cisco 3750X-48P-S

I am unsure if the aruba instant product virtual controller has this capability, when I look at the Aruba Instant 6.3.1.1-4.0 User Guide on page 315, it says this...

 

http://www.arubanetworks.com/techdocs/Instant_41_Mobile/Advanced/Content/UG_files/Wired_port_profile/lacp_support.htm

 

every time I try to type a command such as "interface-profile lacp-profile 1", I am getting a %Parse Error....

 

http://community.arubanetworks.com/t5/Software-User-Reference-Guides/Aruba-Instant-6-4-0-2-4-1-Command-Line-Interface-Reference-Guide/ta-p/168356

 

 

 

 

 

Moderator
Posts: 681
Registered: ‎04-16-2009

Re: Aruba Instant IAP-2250-US with Cisco 3750X-48P-S

The interface profile config snip is for the Aruba switch.   The IAP auto-detects LACP and no configuration is needed on the IAP.

Occasional Contributor II
Posts: 12
Registered: ‎09-03-2014

Re: Aruba Instant IAP-2250-US with Cisco 3750X-48P-S

That's what I thought, so what should the ports and port-channel on switch look like to get the Aruba IAP Auto detect to work?

Moderator
Posts: 681
Registered: ‎04-16-2009

Re: Aruba Instant IAP-2250-US with Cisco 3750X-48P-S

That was a config snip of the LACP config from the switch. With the Aruba switch the command "no independent state" was what got it working for me.  Hopefully there is an equivalent on the Cisco side.

 

interface-profile lacp-profile <NAME>

   group-id 1

   mode active

   timeout short

   no independent-state

Occasional Contributor II
Posts: 12
Registered: ‎09-03-2014

Re: Aruba Instant IAP-2250-US with Cisco 3750X-48P-S

(config-if-range)#channel-group 2 mode ?
  active     Enable LACP unconditionally
  auto       Enable PAgP only if a PAgP device is detected
  desirable  Enable PAgP unconditionally
  on         Enable Etherchannel only
  passive    Enable LACP only if a LACP device is detected

 

I can switch it back to active, but before it wasn't working... 

Search Airheads
Showing results for 
Search instead for 
Did you mean: