Aruba Instant & Cloud Wi-Fi

Reply
Occasional Contributor I
Posts: 8
Registered: ‎06-15-2015

IAP-103 upgraded, wont allow GUI login repeats "turn off mobility" at console

[ Edited ]

Hi,

I have a few IAP-103 access points that were recently upgraded and are no longer allowing me to login to the GUI. If I connect a console cable to them they boot successfully and then start displaying "turn off mobility" over and over. These are IAP-103s with the model # APIN0103. Can anyone help please. 

 

Here is the output from the CLI:


APBoot 1.5.3.21 (build 47715)
Built: 2014-12-17 at 19:19:51

Model: AP-103
CPU: AR9344 revision: 1.2
Clock: 560 MHz, DDR rate: 429 MHz, Bus clock: 214 MHz
DRAM: 128 MB
POST1: passed
Copy: done
Flash: 32 MB
Power: 802.3af POE
PCI: scanning bus 0 ...
dev fn venID devID class rev MBAR0 MBAR1 MBAR2 MBAR3
00 00 168c 0033 00002 01 10000004 00000000 00000000 00000000
Net: eth0
Radio: ar9590#0, ar9344#1

Hit <Enter> to stop autoboot: 0
Booting OS partition 0
Checking image @ 0xbf100000 (bank 1)

Image is signed; verifying checksum... passed
Signer Cert OK
Policy Cert OK
RSA signature verified.
ELF file is 32 bit
Loading .text @ 0x81c00000 (8611832 bytes)
Loading .data @ 0x82436800 (32 bytes)
Clearing .bss @ 0x82436820 (16 bytes)
## Starting application at 0x81c00000 ...
Uncompressing...................................................................................


Aruba Networks
ArubaOS Version 6.4.2.6-4.1.3.2 (build 56106 / label #56106)
Built by p4build@chios on 2016-08-15 at 03:33:19 PDT (gcc version 4.3.3)
CPU Rev: 2122
934x CPU
flash_size passed from bootloader = 32
arg 1: mem=128M
Flash variant: 32M
ath_sys_frequency: cpu apb ddr apb cpu 560 ddr 429 ahb 214
Cache parity protection disabled
ath_timer_init: plat time init done
Using 280.000 MHz high precision timer. cycles_per_jiffy=560000
Memory: 118016k/131072k available (1698k kernel code, 12960k reserved, 673k data, 7712k init, 0k highmem)
available.
detected lzma initramfs
initramfs: LZMA lc=3,lp=0,pb=2,dictSize=8388608,origSize=34441728
LZMA initramfs by Ming-Ching Tiew <mctiew@yahoo.com> ..............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
PCI init:ath_pcibios_init
Returning IRQ 64
ATH GPIOC major 0
wdt: registered with refresh
Enabling Watchdog
Talisker RSSI LED initialization
Concatenating MTD devices:
(0): "bank1"
(1): "bank2"
into device "flash"
Creating 1 MTD partitions on "flash":
0x00000000-0x02000000 : "flash"
i2c /dev entries driver
i2c-talisker: using default base 0x18040000
lo: Disabled Privacy Extensions
IPv6 over IPv4 tunneling driver

Starting Kernel SHA1 KAT ...Completed Kernel SHA1 KAT
Starting Kernel HMAC-SHA1 KAT ...Completed Kernel HMAC-SHA1 KAT
Starting Kernel DES KAT ...Completed Kernel DES KAT
Starting Kernel AES KAT ...Completed Kernel AES KAT

Starting Kernel AESGCM KAT ...Completed Kernel AESGCM KAT

Domain Name: instant.arubanetworks.com
No panic info available
Backup ENV.
ATHR_GMAC: RX TASKLET - Pkts per Intr:16
ATHR_GMAC: Mac address for unit 0:80b0abc0
ATHR_GMAC: 94:b4:0f:cf:6c:8e
ATHR_GMAC: Mac capability flags : 42201
ATHR_GMAC: RX TASKLET - Pkts per Intr:16
ATHR_GMAC: Mac address for unit 1:80b0abc0
ATHR_GMAC: 94:b4:0f:cf:6c:8f
mac:1 Registering S27....
ATHR_GMAC: Mac capability flags : 42A00
athrs17_reg_init:done
Phy setup Complete
Cfg len is 0
Configuration file is empty, turning on default services...
extended ssid activate due to no AP config ...
disable auto topology rules
Starting up in standalone mode
drvlog_mod: module license 'Proprietary' taints kernel.
AP xml model 76, num_radios 2 (jiffies 15240)
init_asap_mod: installation:0
radio 0: band 1 ant 0 max_ssid 16
radio 1: band 0 ant 0 max_ssid 16
election init: rand=a HZ=500
IAP client match init
notify asap_mod 3g no present...
notify asap standalone ap...
Starting watchdog process...
Got all network params from APboot env. Skippingathrs17_reg_init:done
DHCP
Setting PHY...
Phy setup Complete
ADDRCONF(NETDEV_UP): bond0: link is not ready
10.35.21.25 255.255.255.0 10.35.21.1
Compressing all files in the /etc/httpd directory...

Enet:0 port0 up
athr_gmac_poll_link: unit 0 link change to up
ATH_MAC_TIMER: enet unit:0 is up...
Mii 1000Mbps full duplex
ATH_MAC_TIMER: Done cfg2 0x7235 ifctl 0x0 miictrl
ADDRCONF(NETDEV_CHANGE): bond0: link becomes ready
ip_time_handler: Got ip and packets on bond0 Started master election 1-0, rand 24
drvlog_mod: module license 'Proprietary' taints kernel.Done.
Starting Webserver
bind: Transport endpoint is not connected
bind: Transport endpoint is not connected
bind: Transport endpoint is not connected
Launching NTP Client on pool.ntp.org
ath_hal: 0.9.17.1 (AR5416, AR9380, REGOPS_FUNC, PRIVATE_DIAG, WRITE_EEPROM, 11D)
ath_rate_atheros: Copyright (c) 2001-2005 Atheros Communications, Inc, All Rights Reserved
ath_rate_atheros: Aruba Networks Rate Control Algorithm
ath_dfs: Version 2.0.0
Copyright (c) 2005-2006 Atheros Communications, Inc. All Rights Reserved
ath_spectrum: Version 2.0.0
Copyright (c) 2005-2006 Atheros Communications, Inc. All Rights Reserved
ath_dev: Copyright (c) 2001-2007 Atheros Communications, Inc, All Rights Reserved
ath_pci: 0.9.4.5 (Atheros/multi-bss)
Restoring Cal data from Flash
Reading from Addr: 0xbffe5000
ath_attach: scn 85fc0280 sc 85ea0000 ah 85f80000
wifi0: Base BSSID 94:b4:0f:76:c8:f0, 16 available BSSID(s)
bond0 address=94:b4:0f:cf:6c:8e
br0 address=94:b4:0f:cf:6c:8e
wifi0: AP type AP-103, radio 0, max_bssids 16
wifi0: Atheros 9580: mem=0x10000000, irq=64 hw_base=0xb0000000
ath_ahb: 0.9.4.5 (Atheros/multi-bss)
ath_ahb: init_ath_wmac
Enterprise mode: 0x00000000
Restoring Cal data from Flash
Reading from Addr: 0xbffe1000
ath_attach: scn 87f80280 sc 87fa0000 ah 87fc0000
wifi1: Base BSSID 94:b4:0f:76:c8:e0, 16 available BSSID(s)
bond0 address=94:b4:0f:cf:6c:8e
br0 address=94:b4:0f:cf:6c:8e
wifi1: AP type AP-103, radio 1, max_bssids 16
wifi1: Atheros 9340: mem=0xb8100000, irq=2
shutting down watchdog process (nanny will restart it)...
Completed SW FIPS KAT test

<<<<< Welcome to the Access Point >>>>>

User: process `snmpd_sap' is using obsolete setsockopt SO_BSDCOMPAT
i am master now
(00:01:10) !!! Init ---> Master
asap_send_elected_master: sent successfully
turn off mobility
turn off mobility
turn off mobility
turn off mobility
turn off mobility

Guru Elite
Posts: 20,599
Registered: ‎03-29-2007

Re: IAP-103 upgraded, wont allow GUI login repeats &quot;turn off mobility&quot; at console

Please let us know the steps that led to this.  We can only guess with the limited information presented.



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Occasional Contributor I
Posts: 8
Registered: ‎06-15-2015

Re: IAP-103 upgraded, wont allow GUI login repeats &quot;turn off mobility&quot; at console

Thanks for the quick reply. I was having some issues with the APs being stuck in a boot loop so I hooked it up to a serial cable. When I did, it said that there was no Bootable image on partition 0. I then directed it to my tftp server with an updated image and ran the bootap>upgrade os 0 command to upload the new image to partition 0. When it finished successfully, I did a factory reset and rebooted. It now loads to the instant os, but I'm having the issue as described above. If there is any other useful information I can provide please let me know.


#AirheadsMobile
Guru Elite
Posts: 20,599
Registered: ‎03-29-2007

Re: IAP-103 upgraded, wont allow GUI login repeats &quot;turn off mobility&quot; at console

Did you try the reset switch?  Not sure why you would have a bootloop in the first place.



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Occasional Contributor I
Posts: 8
Registered: ‎06-15-2015

Re: IAP-103 upgraded, wont allow GUI login repeats &quot;turn off mobility&quot; at console

Yes, that was my first line of troubleshooting, but when I held down the reset switch to factory default the units they were still trying to boot as if they were looking for a controller instead of booting to the Instant OS.

Guru Elite
Posts: 20,599
Registered: ‎03-29-2007

Re: IAP-103 upgraded, wont allow GUI login repeats &quot;turn off mobility&quot; at console

It seems like you have a controller-based AP.  It cannot be converted to an IAP....



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Occasional Contributor I
Posts: 8
Registered: ‎06-15-2015

Re: IAP-103 upgraded, wont allow GUI login repeats &quot;turn off mobility&quot; at console

I have 8 of these units all with identical model numbers of APIN0103. Three of them are functioning perfectly as they should, as Instant Access Points in a cluster but the others are stuck in this boot loop. They were sold to me as Instant APs and if you look up that model number, Aruba designates that they are in fact Instant APs. I appreciate the input, I just don't understand how some of them would work just fine and some of them wouldn't if they aren't supposed to be Instant.

 

This might be of use:

I just fired up one of the units that I have not modified in any way that is stuck in the boot loop and this is the result:

 01-05-2017 10-45-12 AM.jpg

 

Guru Elite
Posts: 20,599
Registered: ‎03-29-2007

Re: IAP-103 upgraded, wont allow GUI login repeats &quot;turn off mobility&quot; at console

That is a Campus AP.  You should let whoever you purchased that from know that and try to get them to exhange it.  Campus APs cannot be converted to IAPs in the field.  Their personality is set in the manufacturing process, unfortunately.



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Occasional Contributor I
Posts: 8
Registered: ‎06-15-2015

Re: IAP-103 upgraded, wont allow GUI login repeats &quot;turn off mobility&quot; at console

[ Edited ]

So the Model #s are exactly the same for APs and IAPs? I know that didn't use to be the case with the 105s(we currently have AP-105s and IAP-105s). Seems like that would get very confusing.

 

Also, since this is supposedly a Campus AP, shouldn't it be registering with our Campus Controller? Something here just doesn't add up...

 

Do you know why I am getting the error SAPD: Reboot after image upgrade failed: 65280 ?

Guru Elite
Posts: 20,599
Registered: ‎03-29-2007

Re: IAP-103 upgraded, wont allow GUI login repeats &quot;turn off mobility&quot; at console

APIN0103 is the regulatory number, not the model number.

 

A campus AP should register with your controller if a discovery method is configured correctly, the controller is configured to accept foreign APs and the controller has code for that AP model.

 

I don't know why you are getting that error.

 

You should (1) attempt to return the APs and/or (2) contact TAC so that you can get this sorted out.

 

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Search Airheads
Showing results for 
Search instead for 
Did you mean: