Aruba Instant & Cloud Wi-Fi

Reply
Contributor II
Posts: 45
Registered: ‎02-03-2016

IAP Cellular 4G Uplink with Huawei E3276 not working

Hi!

 

After several hours of reading posts and manuals and trying different cellular configurations without success:

 

Whenever I disconnect the ethernet uplink I can see the 3G/4G probe message, but don't get a connection.

 

What could be the problem with my cellular uplink?

 

ISP information:

Country: Austria

ISP: A1

APN: a1.net

Username ppp@a1plus.net

Password: ppp

Access Number: *99#

SIM Lock disabled

 

IAP-215 Version 6.5.0.0-4.3.0.1_57133

 

Cellular configuration:

 

AP1_Meshportal# sh cellular conf
Comm USB Plugged in: Vendor_ID=12d1 Product_ID=1506

Cellular configuration
----------------------
Type            Value
----            -----
4g-usb-type     huawei-cdc
usb-type        huawei-cdc
usb-dev         0x12d11506
usb-tty
usb-init        at+cgdcont=1,'IP','a1.net'
usb-auth-type   PAP
usb-user        ppp@a1plus.at
usb-passwd      ppp
usb-dial        ATDT*99#
usb-modeswitch
modem-isp
modem-country

Supported Modem Types
---------------------
Modem Type      Driver Used
----------      -----------
option          option
acm             acm
airprime        airprime
hso             hso
sierra-evdo     sierra-evdo
sierra-gsm      sierra-gsm
pantech-uml290  pantech-3g
novatal-mc551   ether-3g
sierra-net      sierra-net
franklin-u770   rndis-u770
rndis-l800      rndis-l800
huawei-cdc      huawei-cdc
novatel-u620    novatel-u620
pantech-uml295  rndis-uml295
sierra-gobi     sierra-gobi

Supported Country list
----------------------
Country list
------------
China
UK
Germany
India

Supported ISP list
------------------
ISP list
--------
China Unicom
Vodafone
T-Mobile
Airtel

modem status summary:USB modem attached with detect successful

 

AP1_Meshportal# sh cellular stat

Cellular Status
---------------
card     detect     link      SIM PIN
----     ------     ----      -------
Present  detect-ok  Linkdown  Disable


USB Modem Information
---------------------
Parameter      Value
---------      -----
Manufacturer    HUAWEI
Product         HUAWEI Mobile
Serial Number
Driver          (none)
Vendor ID       12d1
Product ID      1506
cellular history log not available

 

Any idea is welcome!

 

Regards

Manfred

Contributor II
Posts: 45
Registered: ‎02-03-2016

Re: IAP Cellular 4G Uplink with Huawei E3276 not working

[ Edited ]

Hi!

 

The problem is fixed now.

With the help of the Aruba Support Team I've found the problem(s). I've made several mistakes and misunderstood some important things, but the key point was a non-working firmware of the Huawei E3276s-150 3G/4G USB Stick (but worked on my notebook...)

 

Final Parameters for the Austrian Provider ‘A1 Telekom Austria’:

 

AP1_Meshportal# show cellular config

Comm USB Plugged in: Vendor_ID=12d1 Product_ID=1506

 

Cellular configuration

----------------------

Type            Value

----            -----

4g-usb-type

usb-type        huawei-cdc

usb-dev         0x12d11506

usb-tty         ttyUSB0

usb-init        AT+CGDCONT=1,"IP","A1.net"

usb-auth-type   PAP

usb-user        ppp@a1plus.at

usb-passwd      ppp

usb-dial        ATDT*99#

usb-modeswitch

modem-isp

modem-country

 

It would also work with the usb-type option but this is the 3G/PPPD driver.

 

Details of the troubleshooting process and additional hints:

Take care with the values of usb-init and usb-dial (APN Settings) and especially the uplink configuration and priority. To test the 3G/4G uplink it must have the highest priority (1 or 2) in relation to the eth0 and Wifi priority.

 

I found a diagnostic window in the regular internet connection tool of the 3g/4G Stick under Windows with the correct provider information.

Also try to change the usb-tty value to ttyUSB1.


Find International APN Settings here:
http://www.hw-group.com/products/HWg-Ares/HWg-Ares_GSM_APN_en.html

 

There are 2 types of the firmware on these Huawei sticks E3276s-150:

(you can find the correct type of your stick on a label inside the stick - there are many types out there)

- Normal Version 21.x.x.x.x

- HiLink Version 22.x.x.x.x

 

In the beginning I had the firmware version 21.260.05.00.618 on the 3G/4G stick which did not work!

After an upgrade to firmware version 21.491.05.00.00 (Universal) the 4G Uplink worked (found this firmware on the web - maybe it's unofficial, but it's still working also with the same dial-In tool on my notebook)
Firmware source:

https://routerunlock.com/download-firmware-huawei-e3276-hilink-normal-modem/
Use unofficial firmware at your own risk - don't call me...

 

I did not test the HiLink firmware - I think that there's no way back to the 'normal' 21.x.x.x.x version - I didn't want to break the stick...

 

For debugging it's best to carefully examine at the output of the bootlog (console output). Believe me - you can learn a lot!

 

The following commands are also helpful:

show uplink config
show uplink status
show cell status
show cell config
show log pppd

show log lte

and of course:

show tech-support

 

You can find the bootlog, outputs of these commands and the output of the show tech-support and a screenshot of the settings in the GUI of my working environment attached.

 

The tests have been done with the Early Deployment Release 6.5.0.0-4.3.0.1 (build 57133)

I have tested this configuration with the General Availability Instant Release 6.4.4.8-4.2.4.5 (build 57965) also successfully.

 

Good luck and Thanks to the Aruba Support Team!

Manfred

 

Search Airheads
Showing results for 
Search instead for 
Did you mean: