Aruba Instant & Cloud Wi-Fi

Reply
Occasional Contributor I
Posts: 7
Registered: ‎04-12-2013

IAP1-5 stuck in reboot loop

Below is output from the console. Ideas?

 

 

 

APBoot 1.2.4.4 (build 26618)
Built: 2011-01-07 at 13:42:04

Model: AP-10x
CPU: AR7161 revision: A2
Clock: 680 MHz, DDR clock: 340 MHz, Bus clock: 170 MHz
DRAM: 128 MB
POST1: passed
Copy: done
Flash: 16 MB
PCI: scanning bus 0 ...
dev fn venID devID class rev MBAR0 MBAR1 MBAR2 MBAR3
00 00 168c 0029 00002 01 10000000 00000000 00000000 00000000
01 00 168c 0029 00002 01 10010000 00000000 00000000 00000000
Net: eth0
Radio: ar922x#0, ar922x#1

Hit <Enter> to stop autoboot: 0
Booting OS partition 0
Checking image @ 0xbf100000

Image is signed; verifying checksum... passed
Signer Cert OK
Policy Cert OK
RSA signature verified.
ELF file is 32 bit
Loading .text @ 0x80e00000 (6299544 bytes)
Loading .data @ 0x81401fa0 (32 bytes)
Clearing .bss @ 0x81401fc0 (16 bytes)
## Starting application at 0x80e00000 ...
Uncompressing............................................................

Aruba Networks
ArubaOS Version 6.2.1.0-3.4.0.3 (build 40346 / label #40346)
Built by p4build@cyprus on 2013-10-11 at 19:10:16 PDT (gcc version 4.3.3)
CPU Rev: aa
71x CPU
Flash variant: default
Cache parity protection disabled
Using 340.000 MHz high precision timer. cycles_per_jiffy=680000
Memory: 120576k/131072k available (1687k kernel code, 10400k reserved, 625k data, 5484k init, 0k highmem)
available.
detected lzma initramfs
initramfs: LZMA lc=3,lp=0,pb=2,dictSize=8388608,origSize=27214848
LZMA initramfs by Ming-Ching Tiew <mctiew@yahoo.com> ................................................................................................................................................................................................................................................................................................................................................................................................................................
AR7100 GPIOC major 0
wdt: registered with refresh
Enabling Watchdog
Talisker RSSI LED initialization
Creating 1 MTD partitions on "ar7100-nor0":
0x00000000-0x01000000 : "flash"
i2c /dev entries driver
i2c-talisker: using default base 0x18040000
AD7416 driver probing for devices on AR7100 I2C
.<6>lo: Disabled Privacy Extensions
IPv6 over IPv4 tunneling driver

Starting Kernel SHA1 KAT ...Completed Kernel SHA1 KAT
Starting Kernel HMAC-SHA1 KAT ...Completed Kernel HMAC-SHA1 KAT
Starting Kernel DES KAT ...Completed Kernel DES KAT
Starting Kernel AES KAT ...Completed Kernel AES KAT

Domain Name: arubanetworks.com
Testing TPM... Passed
ag7100_mod: module license 'unspecified' taints kernel.
AG7100: Length per segment 512
AG7100: Max segments per packet 4
AG7100: Max tx descriptor count 400
AG7100: Max rx descriptor count 252
AG7100: fifo cfg 3 018001ff
AG7100CHH: Mac address for unit 0
AG7100CHH: d8:c7:c8:cd:b1:41
ATHRF1: Port 0, Neg Success
ATHRF1: unit 0 phy addr 0 ATHRF1: reg0 0
ag7100_ring_alloc Allocated 4800 at 0x8086a000
ag7100_ring_alloc Allocated 3024 at 0x86e13000
AG7100: cfg1 0xf cfg2 0x7014
ATHRF1: Port 0, Neg Success
ATHRF1: unit 0 phy addr 0 ATHRF1: reg0 3100
AG7100: unit 0: phy not up carrier 1
Writing 4
ADDRCONF(NETDEV_UP): bond0: link is not ready
wifi uplink not present...
Ethernet uplink not active yet
Ethernet uplink not active yet
AG7100: unit 0 phy is up...RGMii 100Mbps full duplex
AG7100: pll reg 0x18050010: 0x1099 AG7100: cfg_1: 0x1ff0000
AG7100: cfg_2: 0x3ff
AG7100: cfg_3: 0x18001ff
AG7100: cfg_4: 0xffff
AG7100: cfg_5: 0x7ffef
AG7100: done cfg2 0x7115 ifctl 0x10000 miictrl 0x12
ADDRCONF(NETDEV_CHANGE): bond0: link becomes ready
Ethernet uplink active. Becoming Mesh Portal
AP xml model 39, num_radios 2 (jiffies 17458)
init_asap_mod: installation:0
radio 0: band 1 ant 0 max_ssid 8
radio 1: band 0 ant 0 max_ssid 8
election init: rand=1d HZ=500
setting bond0 as bridge child
setting gre0 as split child
notify asap_mod 3g no present...
Starting watchdog process...
Getting an IP address...
Dec 31 16:00:35 udhcpc[813]: udhcpc (v0.9.9-pre) started
Dec 31 16:00:35 udhcpc[813]: send_discover: pkt num 0, secs 0
Dec 31 16:00:35 udhcpc[813]: Sending discover...
Dec 31 16:00:35 udhcpc[813]: send_selecting: pkt num 0, secs 0
Dec 31 16:00:35 udhcpc[813]: Sending select for 10.0.1.74...
Dec 31 16:00:35 udhcpc[813]: Lease of 10.0.1.74 obtained, lease time 86400
Dec 31 16:00:35 udhcpc[813]: DHCP OPT 43 deleted airwave config

10.0.1.74 255.255.255.0 10.0.1.1
Compressing all files in the /etc/httpd directory...
ip_time_handler: Got ip and packets on bond0 Started master election 105-0
Done.
Starting Webserver
bind: Transport endpoint is not connected
bind: Transport endpoint is not connected
bind: Transport endpoint is not connected
NTP Server not saved in flash... using default
ath_hal: 0.9.17.1 (AR5416, AR9380, REGOPS_FUNC, PRIVATE_DIAG, WRITE_EEPROM, 11D)
ath_rate_atheros: Copyright (c) 2001-2005 Atheros Communications, Inc, All Rights Reserved
ath_rate_atheros: Aruba Networks Rate Control Algorithm
ath_dfs: Version 2.0.0
Copyright (c) 2005-2006 Atheros Communications, Inc. All Rights Reserved
ath_spectrum: Version 2.0.0
Copyright (c) 2005-2006 Atheros Communications, Inc. All Rights Reserved
ath_dev: Copyright (c) 2001-2007 Atheros Communications, Inc, All Rights Reserved
ath_pci: 0.9.4.5 (Atheros/multi-bss)
ath_dev_attach: unable to attach hardware; HAL status 14
wifi0: Base BSSID d8:c7:c8:5b:14:18, 8 available BSSID(s)
bond0 address=d8:c7:c8:cd:b1:41
br0 address=d8:c7:c8:cd:b1:41
wifi0: AP type AP-105, radio 0, max_bssids 8
wifi0: Atheros 9280: mem=0x10000000, irq=48 hw_base=0xb0000000
ath_ahb: 0.9.4.5 (Atheros/multi-bss)

Starting FIPS KAT ... Failed FIPS KAT.
shutting down watchdog process (nanny will restart it)...

<<<<< Welcome to the Access Point >>>>>

Launching IAP CLI...
process `snmpd' is using obsolete setsockopt SO_BSDCOMPAT

i am master now
(19:46:40) !!! Init ---> Master
asap_send_elected_master: sent successfully
User: wifi0: Channel 157 cc=348 not found
no bss chan on aruba000Break instruction in kernel code[#1]:
Cpu 0
$ 0 : 00000000 00000000 0000001a 80315940
$ 4 : 80315940 00000001 00000007 00000002
$ 8 : 808e3b24 ffffffff 0000003c 00000000
$12 : 00000000 00000020 00000006 0000001f
$16 : 85bdf828 85fd8000 857c8280 86f80280
$20 : 85fd8289 857ca3e8 85fd8000 0000001a
$24 : 00000000 c010140c
$28 : 80520000 80521c00 0000a830 c09c72a4
Hi : 000000e2
Lo : 4dd56000
epc : c09c72a4 ieee80211_ifattach+0x780/0x1188 [wlan] Tainted: P
ra : c09c72a4 ieee80211_ifattach+0x780/0x1188 [wlan]
Status: 1000d402 KERNEL EXL
Cause : 5080c424
PrId : 00019374
Modules linked in: kat ath_pktlog wlan_scan_sta wlan_wep wlan_tkip wlan_ccmp ath_pci ath_dev spectrum dfs ath_rate_atheros ath_hal wlan asap_mod drvlog_mod ag7100_mod
Process meshd (pid: 1083, threadinfo=80520000, task=80516ab8)
Stack : 857ca3e8 857c8000 85bdf828 00000000 00000000 000005fa 0000001a 8545ae00
857c8280 857ca3e8 86f80280 c09c962c 0000000d c0962f48 80521cb8 808e5144
808d8710 8026fbdc 85bdf828 86a80000 857c8280 85fd8000 8540f410 86f80280
8540f40c 00000000 86a83c8c c0963b20 80521c78 8012317c 00000000 857c8280
00000000 80353000 8540f400 86a80000 00000000 c0a5c874 00000000 8021bf88
...
Raw Call Trace:
[<c09c962c>] ieee80211_beacon_alloc+0x25c/0x440 [wlan]
[<c0962f48>] ath_set_ratecap+0x2fc/0xba0 [ath_pci]
[<8026fbdc>] addrconf_add_linklocal+0x3c/0x80
[<c0963b20>] wlan_iterate_vap_list+0x324/0x66c [ath_pci]
[<8012317c>] __wake_up+0x30/0x58
[<80353000>] vfs_caches_init_early+0x7c/0xa0
[<c0a5c874>] ath_beacon_alloc+0xa8/0x214 [ath_dev]
[<8021bf88>] netlink_broadcast+0x3ac/0x46c
[<c0a627e0>] ath_dfs_war_task+0x520/0x930 [ath_dev]
[<80215250>] rtmsg_ifinfo+0xe4/0x100
[<c0965a0c>] ath_newstate+0x2c0/0x18f4 [ath_pci]
[<80127d34>] printk+0x0/0x30
[<c09eb504>] ieee80211_new_state+0xb8/0xf0 [wlan]
[<8020c1d0>] dev_open+0xc8/0xd0
[<c09ec73c>] ieee80211_init+0x408/0x450 [wlan]
[<8013c25c>] autoremove_wake_function+0x0/0x4c
[<801ff124>] sock_aio_write+0x58/0x70
[<8020c168>] dev_open+0x60/0xd0
[<8020ac8c>] dev_change_flags+0x70/0x154
[<8020c6c8>] dev_ifsioc+0x20/0x470
[<8024b230>] devinet_ioctl+0x2b0/0x710
[<8020cf1c>] dev_ioctl+0x404/0x694
[<80200d6c>] sock_ioctl+0x300/0x350
[<80178fec>] do_ioctl+0x2c/0x78
[<801ffc4c>] __sock_create+0x128/0x248
[<8017930c>] vfs_ioctl+0x2d4/0x308
[<80179390>] sys_ioctl+0x50/0x90
[<802011f0>] sys_socket+0x24/0x48
[<801136c4>] stack_done+0x20/0x3c

Stack : 857ca3e8 857c8000 85bdf828 00000000 00000000 000005fa 0000001a 8545ae00
857c8280 857ca3e8 86f80280 c09c962c 0000000d c0962f48 80521cb8 808e5144
808d8710 8026fbdc 85bdf828 86a80000 857c8280 85fd8000 8540f410 86f80280
8540f40c 00000000 86a83c8c c0963b20 80521c78 8012317c 00000000 857c8280
00000000 80353000 8540f400 86a80000 00000000 c0a5c874 00000000 8021bf88
...
Unwound Call Trace:
[<c09c72a4>] ieee80211_ifattach+0x780/0x1188 [wlan]
[<c0963b20>] wlan_iterate_vap_list+0x324/0x66c [ath_pci]


Code: 24427d34 0040f809 24844ad0 <0200000d> 3c02801c 00002821 02002021 244205c0 0040f809
wdt_ar7100_refresh: Enabling kernel refresh of watchdog.
Time Sun Dec 8 19:46:52 2013: Flash erase @ 0xbff70000

Super Contributor I
Posts: 324
Registered: ‎05-09-2013

Re: IAP1-5 stuck in reboot loop

Is this IAP factory default or previously configured? Is this the only IAP in the cluster? I noticed it said Master so I assume it's the first you've powered up?

Michael Haring | Network Engineer - ACMP, ACCP
Comm Solutions Company | www.commsolutions.com
MVP
Posts: 4,077
Registered: ‎07-20-2011

Re: IAP1-5 stuck in reboot loop

 

It looks like the IAP is not able to get an IP ?

Thank you

Victor Fabian
Lead Mobility Engineer @ Integration Partners
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
Guru Elite
Posts: 7,987
Registered: ‎09-08-2010

Re: IAP1-5 stuck in reboot loop

Looks like option 43 is configured in your DHCP server. Are you trying to
bring it up fresh or pull a config from AirWave?

Tim Cappalli | Aruba ClearPass TME
@timcappalli | ACMX #367 / ACCX #480 / ACEAP / CWSP
Aruba Employee
Posts: 12
Registered: ‎05-27-2013

Re: IAP1-5 stuck in reboot loop

which country-code we run? It seemed this IAP running with a country-code we not support.

Occasional Contributor I
Posts: 7
Registered: ‎04-12-2013

Re: IAP1-5 stuck in reboot loop

This is factory default, yes at the time it was the only AP.  I have another that boots up just fine, but I have not configured that one either.

Occasional Contributor I
Posts: 7
Registered: ‎04-12-2013

Re: IAP1-5 stuck in reboot loop

It is getting an IP, 10.0.1.74. The web interface is very briefly available, sometimes even long enough to log in, but not more than a few seconds before rebooting.

Occasional Contributor I
Posts: 7
Registered: ‎04-12-2013

Re: IAP1-5 stuck in reboot loop

Boot up fresh, as far as I can tell I don't have option 43 configured in my DHCP server.  

Occasional Contributor I
Posts: 7
Registered: ‎04-12-2013

Re: IAP1-5 stuck in reboot loop

How do I determine country code?

Aruba Employee
Posts: 200
Registered: ‎07-14-2013

Re: IAP1-5 stuck in reboot loop

Could you get into APBOOT via the console connection , run the command 'mfginfo' and share with us the result?
Search Airheads
Showing results for 
Search instead for 
Did you mean: