Aruba Instant & Cloud Wi-Fi

Reply
New Contributor
Posts: 2
Registered: ‎08-18-2015

external captive portal not working

We have setup an external captive portal page for guest access, basically it displays an AUP and forces the user to click on an Accept button.  We used this code to make the post back to the instant APs:

 

<form method="POST" ACTION="http://securelogin.arubanetworks.com/swarm.cgi">
<input type="hidden" name="user" value="guest">
<input type="hidden" name="password" value="guest">
<input type="submit" name="Accept" value="authenticate">
</form>

 

Now we have two problems, first of all when the user connects, the captive portal page loads just fine but when they click on the Accept button they are redirected to a blank page at http://securelogin.arubanetworks.com/swarm.cgi, but they are allowed onto the network.  The second issue is that if the user doesn't click on Accept and instead closes the window, then they are still allowed onto the network.

 

Here is a screenshot of the blank swarm.cgi page

New Contributor
Posts: 2
Registered: ‎08-18-2015

Re: external captive portal not working

So we figured it out.  Our first issue was trying to use authenticated text instead of Raduis Authentication in the captive portal settings, the second issue was that we were trying to access the external captive portal by name instead of IP address.  We simply can not figure out a way to handle the dns lookup for the unauthenticated user.  It's working now, via IP address, and that is all that matters.  Also, I'm attaching a guide that was very helpful that a partner shared with us.

Valued Contributor II
Posts: 804
Registered: ‎12-01-2014

Re: external captive portal not working

HI,

 

To diagnose this issue, please use "show acl hits" and identify which all ACL are hitting for that user. this looks like a policy mapped to that user role.

 

Please feel free for any further help on this.

Cheers,
Venu Puduchery,
[Is my post helped you ? Give Kudos :) ]
Contributor I
Posts: 31
Registered: ‎01-03-2014

Re: external captive portal not working

caleb1946

 

Came across your article as I was trying to do the same on an IAP-325, although ran into a few snags. I suspect my FQDN is being returned correctly as the controller intercepts the dns query for instant.arubanetworks.com.

 

I was just wondering if you were still using this feature, and what code release were you on. 

 

Thanks,

Justin

Justin Kwasnik | ACMX# 598 ACCP
Search Airheads
Showing results for 
Search instead for 
Did you mean: