ArubaOS and Controllers

Reply
Occasional Contributor II
Posts: 12
Registered: ‎06-29-2010

Aruba Vlans and Dell Switches

Hi,

My whole network is built on Dell Powerconnect 6224P and 6248P switches, I'm trying to change my network in multiple VLANs but when I try to connect a port defined as trunk from Aruba 6000 to pass all VLANs traffic to a Dell Switch, nothing passes through. (Dell switch also has the port defined as trunk with same VLAN IDs).

If I use the ports in access mode they both recognize the Vlan assigned.

Anyone has knowledge on VLANs with Aruba and Dell Switches ?
Help would be greatly appreciated,

Regards,
Aruba
Posts: 760
Registered: ‎05-31-2007

Aruba Vlans and Dell Switches

I have many deployments with Dell LAN <--> Aruba controllers.

What does the configuration of each side look like ?
Occasional Contributor II
Posts: 12
Registered: ‎06-29-2010

Re: Aruba Vlans and Dell Switches

Configurations are as follows:

I had defined VLANs 10-16, 21-26, 31-33 in both Aruba and Dell.


Aruba 6000:

interface gigabitethernet 0/10
description "XG0/10"
trusted
trusted vlan 1-4094
switchport mode trunk
no spanning-tree
!

Dell 6224P:

interface ethernet 1/XG1
channel-group 10 mode auto
exit
!
interface port-channel 10
switchport mode trunk
switchport trunk allowed vlan add 10-16,21-26,31-33
switchport trunk allowed vlan remove 1
exit
!
Aruba
Posts: 760
Registered: ‎05-31-2007

Aruba Vlans and Dell Switches

So one side is a port channel and the other is a standard trunk ?

I would have pursued something like this on the Dell side:

console(config)# interface ethernet 1/XG1
console(config-if)# switchport mode trunk
console(config-if)# switchport allowed vlan add 10-16,21-26,31-33 tagged
console(config-if)# exit

Have you tried this style of config to 'match' whats on the controller side ?
Occasional Contributor II
Posts: 12
Registered: ‎06-29-2010

Re: Aruba Vlans and Dell Switches

No, I have not try this style.
I will try this configuration and let you know.

Thanks for your help.
Aruba
Posts: 760
Registered: ‎05-31-2007

Aruba Vlans and Dell Switches

Anytime.

Good luck. ;) and if it still doesn't work from there we can debug further of course...
New Contributor
Posts: 1
Registered: ‎07-21-2011

Re: Aruba Vlans and Dell Switches

Alfspace98,

did you have any luck with this? I am having the same issue with a dell 6248 and an aruba 3400 controller.
Aruba
Posts: 760
Registered: ‎05-31-2007

Aruba Vlans and Dell Switches

Alf,

Do you want to post your configs here as well ?

Likely will help move this along.
Search Airheads
Showing results for 
Search instead for 
Did you mean: