ArubaOS and Controllers

Reply
Occasional Contributor I
Posts: 6
Registered: ‎12-12-2008

Command Reversal Help: "no snmp-server"

The command "no snmp-server" was entered and written to memory on one of our controllers and I cannot find a way to reverse this command. The only thing we've come up with is to reload with an older config.

Does anyone know an easier way to reverse this command (or just turn SNMP back on)? The specific version in question is 3.3.3.4 but I tried to upgrade to 3.4.2.2 on a test box and that didn't give me any additional options (that I can find).

Thanks.

Chuck White
University of Alabama-Birmingham
Guru Elite
Posts: 21,272
Registered: ‎03-29-2007

What are you missing?


The command "no snmp-server" was entered and written to memory on one of our controllers and I cannot find a way to reverse this command. The only thing we've come up with is to reload with an older config.

Does anyone know an easier way to reverse this command (or just turn SNMP back on)? The specific version in question is 3.3.3.4 but I tried to upgrade to 3.4.2.2 on a test box and that didn't give me any additional options (that I can find).

Thanks.

Chuck White
University of Alabama-Birmingham




(viking.arubanetworks.com) #show snmp ?
community Display the configured snmp communities
engine-id Display the configured snmp engine ID
inform Inform queue
trap-hosts Display the configured trap hosts
trap-list All the traps in the controller
trap-queue Display the Trap Queue
user-table Display the configured snmp users



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Aruba Employee
Posts: 41
Registered: ‎04-02-2007

Re: Command Reversal Help: "no snmp-server"

If you know the SNMP server configuration or are able to retrieve it from an older config file, just enter it again. SNMP service is enabled once you have the right community/user configuration.


(Aruba5000) (config) #snmp-server ?
community set read-only community string
enable Enable SNMP Traps
engine-id Engine ID of SNMP server in HEX.
host Specify host address to receive SNMP notifications.
inform SNMP Inform parameters
source Configure source address of SNMP responses
stats Enable File based Stats collection
trap SNMP Trap parameters
user User Name configuration for the USM security model
Occasional Contributor I
Posts: 6
Registered: ‎12-12-2008

Re: Command Reversal Help: "no snmp-server"

Thanks for the responses.

I've tried replacing the snmp community strings but snmp still doesn't respond to a walk and the "no snmp-server" command is still within the configuration.

None of the commands that I originally issued are missing, just the one line added.

If you issue the following two commands, you will notice that the options available are slightly different (this is version 3.4.2.2). I hoping to remove it without a reboot and just in case it happens again.

(TEST1) (config) #snmp-server ?
community set read-only community string
enable Enable SNMP Traps
engine-id Engine ID of SNMP server in HEX.
host Specify host address to receive SNMP notifications.
inform SNMP Inform parameters
source Configure source address of SNMP responses
stats Enable File based Stats collection
trap SNMP Trap parameters
user User Name configuration for the USM security model

(TEST1) (config) #no snmp-server ?
community set read-only community string
enable Enable SNMP Traps
engine-id Engine ID of SNMP server in HEX.
host Specify host address to receive SNMP notifications.
source Configure source address of SNMP responses
stats Enable File based Stats collection
trap SNMP Trap parameters
user User Name configuration for the USM security model


Thanks again for the help.
Contributor I
Posts: 54
Registered: ‎06-19-2009

no snmp-server

Hi, I have run into the same problem. Apparently this is a known bug 'as per aruba support'. I had to manually edit my default.cfg and remove the entry.


jason
Occasional Contributor I
Posts: 6
Registered: ‎12-12-2008

"no snmp-server" = known issue

Thanks Jason. That, at least, tells me which way I need to go.
Search Airheads
Showing results for 
Search instead for 
Did you mean: