ArubaOS and Controllers

Reply
Occasional Contributor II

DHCP and WPA2 not working ???

I have an issue that has me rather stumped.

If I use the WLAN Wizard to create a new WLAN on VLAN 1 for internal use, select "Strong encryption but without link-layer authentication. All users share same encryption key" and configure WPA2 TKIP or WPA2 AES, the machines that connect to the WLAN constantly have their DHCP addresses reset. I get messages saying that the IP is in use by another machine on the network.

I immediately jumped to the idea that I must have a problem with spanning tree, but after sleuthing that out for several hours this afternoon, I gave up and configrued the controller from scratch again.

This time, I created a WLAN using the same settings as above, but instead of choosing "Strong encryption...", I selected "Open."

I was able to connect my clients and DHCP didn't freak out.

So I went back and created a WLAN using "Strong encryption..." and whammo... when client connects to the testClosed WLAN DHCP begins to freak out immediately... connect them to testOpen and all is well.

What could be causing this?

I am using an external DHCP server, but that has been serving my network for some time with no issues.

I have tried this with dhcp helper configured, and blank.

I have tried flagging the ports that the APs are connected to as untrusted... that didn't help either.

I can't even comprehend why this is an issue.

Ideas?
Guru Elite

Re: DHCP and WPA2 not working ???

What role does the client get when he attaches to the encrypted network?
Did you use VLAN1 as well when the client attached to the encrypted network?


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Occasional Contributor II

Re: DHCP and WPA2 not working ???

There is only one van (01) and everybody seems to end up in the logon role in all cases above.
Occasional Contributor II

Re: DHCP and WPA2 not working ???

Do I _need_ to use additional VLANs?
Guru Elite

Re: DHCP and WPA2 not working ???

If you do not have the PEF-NG license, some things are configured slightly different. You should not need an additional VLAN.

Does the client say what mac address has the same ip address?


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: