ArubaOS and Controllers

Reply
New Contributor

Disable First Start Wizard

Please let me know if there is an easier way to do this, because it seems painful the way I am doing it.

I get shipped 620's with either 3.4 or 5.0 firmware.

I unbox it, cable it to my pc.

I use the serial connection for all of this.

It comes up to the wizard, I accept all values.
I then update the firmware via ftp from my pc to 6.0.0.1
it reboots --- WHY DOES THIS TAKE 6 minutes.

Then I have to add license keys (firewall) and do a write erase so it rebuilds the config with a firewall license.

Then reboot (6 minutes)

Then it comes up, I have to run through the wizard again using the values I actually want.

REBOOT AGAIN.

Now its up, although my local controllers can never see my master and visa-versa, they are connected through vpns, I can ping both, but they cannot ping each other.

This all takes 3 reboots from the time I get the device to actually being able to use it, which in turns ends up taking at least 30 minutes of my time.

Please advise me on some way to speed this up, in my eyes this device should take 1-2 minutes to boot and I would just need to apply a firmware update and paste a config, not have to go through a wizard which forces me to reboot.
Guru Elite

Re: Disable First Start Wizard

Use the console to assign an ip address to the device; reboot
Add license and upgrade image at the same time; reboot
The controllers take that long to reboot, but it should improve in the next major release.
The controllers probably cannot ping each other because you have the wrong ipsec key, or the tunnel is not up.


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

New Contributor

Re: Disable First Start Wizard


Use the console to assign an ip address to the device; reboot
Add license and upgrade image at the same time; reboot
The controllers take that long to reboot, but it should improve in the next major release.
The controllers probably cannot ping each other because you have the wrong ipsec key, or the tunnel is not up.




I have tried setting up the ipsec keys multiple times, but I know the tunnel is not up.

master ip 192.168.0.7
local ip 10.32.9.5

I will refer to them as 7 and 5

7 can ping everything on 5's network.
5 can ping everything on 7's network.

5 can not ping 7, 7 can not ping 5

Somehow, I end up messing around with uplink enable/disabling, and setting something to use vlan 1 and it eventually works. With this one, it is not working. All I have pretty much done is gone through the wizard, as the master should push down the config to the local.
New Contributor

Re: Disable First Start Wizard

The problem was the ipsec key, one was encrypted, one was not. I put both in via the web interface but apparently, that wasn't enough. By default the web interface does not add vlan 1 to the end which I need for my setup.

ex:
masterip x.x.x.x ipsec keyname vlan 1



The reboot problem, that is really a feature request. What is the best method for me to request this.

On the aruba 620, with console access, it boots up and starts a wizard asking for name, master or local, etc... At the end of this wizard it will reboot your controller. I am requesting that at the end of the wizard, it ASKS you to reboot and you at least have the option of choosing no. Then you could login, apply your license keys, and then reload to save at least one reboot.

Where should I request this?
Guru Elite

Re: Disable First Start Wizard

Matt,

You can contact your local Aruba Sales team, or if you PM me with your organization, I can request it for you.


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: