Reply
Occasional Contributor II
Posts: 10
Registered: ‎04-28-2009

Lacp

Do you know of any more specific documentation on LACP besides what is in the manual? I noticed that LACP will automatically inherit a port channel's properties. So is the best method to lag 2 ports together is maybe to set up a port channel for the ports first? What happens if there is not a port channel? If anyone has setup LACP on their M3's, please share.

Angela Hollman
Guru Elite
Posts: 20,780
Registered: ‎03-29-2007

Re: Lacp

It is better to setup the port channel first; that way, when you add the interfaces they will be configured as you want them in the port channel. Either way, when doing any aggregation of ports, we would encourage you to do the configuration using the serial port of the controller, just in case you make an error (you probably already know this).

Below is a snippet of LACP configuration (not necessarily in order):

============================================
=== CISCO SWITCH CONFIG ====================
============================================
!
interface FastEthernet6/39
switchport access vlan 14
switchport mode access
channel-group 2 mode active
spanning-tree portfast
!
interface FastEthernet6/40
switchport access vlan 14
switchport mode access
channel-group 2 mode active
spanning-tree portfast
!
interface FastEthernet6/41
switchport access vlan 14
switchport mode access
channel-group 2 mode active
spanning-tree portfast
!
interface Port-channel2
description Connected to Aruba-Controller
switchport
switchport access vlan 14
switchport mode access
!

============================================
=== ARUBA CONFIG ===========================
============================================
!
interface gigabitethernet 1/1
description "GE1/1"
trusted
trusted vlan 1-4094
lacp group 2 mode active
!
interface gigabitethernet 1/2
description "GE1/2"
trusted
trusted vlan 1-4094
lacp group 2 mode active
!
interface gigabitethernet 1/3
description "GE1/3"
trusted
trusted vlan 1-4094
lacp group 2 mode active
!
interface port-channel 2
trusted
trusted vlan 1-4094
!

============================================
=== ARUBA LACP SHOW COMMANDS ===============
============================================

(SWF) #show lacp 2 neighbor

Flags: S - Device is requesting slow LACPDUs
F - Device is requesting fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
LACP Neighbor Table
-------------------
Port Flags Pri OperKey State Num Dev Id
---- ----- --- ------- ----- --- ------
GE 1/2 SA 32768 0x2 0x3d 0xc0 00:13:19:6A:4D:80
GE 1/3 SA 32768 0x2 0x3d 0xc2 00:13:19:6A:4D:80
GE 1/1 SA 32768 0x2 0x3d 0xc1 00:13:19:6A:4D:80


(SWF) #show lacp 2 counters

LACP Counter Table
------------------
Port LACPDUTx LACPDURx MrkrTx MrkrRx MrkrRspTx MrkrRspRx ErrPktRx
---- -------- -------- ------ ------ --------- --------- --------
GE 1/2 95 92 0 0 0 0 0
GE 1/3 96 90 0 0 0 0 0
GE 1/1 92 88 0 0 0 0 0


(SWF) #show lacp 2 internal

Flags: S - Device is requesting slow LACPDUs
F - Device is requesting fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
LACP Internal Table
-------------------
Port Flags Pri AdminKey OperKey State Num Status
---- ----- --- -------- ------- ----- --- ------
GE 1/2 SA 255 0x3 0x3 0x3d 0x3 up
GE 1/3 SA 255 0x3 0x3 0x3d 0x4 up
GE 1/1 SA 255 0x3 0x3 0x3d 0x2 up


(SWF) #show lacp sys-id

32768,00:0B:86:61:66:14


(SWF) #show interface port-channel 2
Port-Channel 2 is administratively up
Hardware is Port-Channel, address is 00:00:00:00:00:00 (bia 00:0B:86:61:66:17)
Description: Link Aggregate (LACP)
Spanning Tree is forwarding
VLAN membership: 1
Switchport priority: 0
Member port:
GE 1/2, Admin is up, line protocol is up
GE 1/3, Admin is up, line protocol is up
GE 1/1, Admin is up, line protocol is up
Last clearing of "show interface" counters 0 day 0 hr 52 min 54 sec
link status last changed 0 day 0 hr 21 min 27 sec
34355 packets input, 2882907 bytes
Received 10165 broadcasts, 0 runts, 0 giants, 0 throttles
456 input error bytes, 0 CRC, 0 frame
4811 multicast, 24190 unicast
17102 packets output, 1904307 bytes
0 output errors bytes, 0 deferred
0 collisions, 0 late collisions, 0 throttles
Port-Channel 2 is TRUSTED


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Occasional Contributor II
Posts: 10
Registered: ‎04-28-2009

Lacp

Thanks for your response. I will be trying this shortly. I appreciate the CLI commands. That is where I usually work.

Ang
Occasional Contributor I
Posts: 5
Registered: ‎08-28-2010

Re: Lacp


It is better to setup the port channel first; that way, when you add the interfaces they will be configured as you want them in the port channel. Either way, when doing any aggregation of ports, we would encourage you to do the configuration using the serial port of the controller, just in case you make an error (you probably already know this).

Below is a snippet of LACP configuration (not necessarily in order):

============================================
=== CISCO SWITCH CONFIG ====================
============================================
!
interface FastEthernet6/39
switchport access vlan 14
switchport mode access
channel-group 2 mode active
spanning-tree portfast
!
interface FastEthernet6/40
switchport access vlan 14
switchport mode access
channel-group 2 mode active
spanning-tree portfast
!
interface FastEthernet6/41
switchport access vlan 14
switchport mode access
channel-group 2 mode active
spanning-tree portfast
!
interface Port-channel2
description Connected to Aruba-Controller
switchport
switchport access vlan 14
switchport mode access
!

============================================
=== ARUBA CONFIG ===========================
============================================
!
interface gigabitethernet 1/1
description "GE1/1"
trusted
trusted vlan 1-4094
lacp group 2 mode active
!
interface gigabitethernet 1/2
description "GE1/2"
trusted
trusted vlan 1-4094
lacp group 2 mode active
!
interface gigabitethernet 1/3
description "GE1/3"
trusted
trusted vlan 1-4094
lacp group 2 mode active
!
interface port-channel 2
trusted
trusted vlan 1-4094
!




Wouldn't you be creating an access port on the Cisco with vlan 14 in one end and a 802.1q trunk on the Aruba with vlan 1-4094? If so vlan 14 would be untagget from the Cisco port and would be recognized by as Aruba as vlan 1 (as the default untagged vlan)?
Guru Elite
Posts: 20,780
Registered: ‎03-29-2007

Re: Lacp

There is no word "Trunk" on the Aruba side. It would be an access port.


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Frequent Contributor I
Posts: 108
Registered: ‎09-26-2008

Re: Lacp

Do make sure that the ports have the same setting when configuring LACP...

Just my 2 cents...

Michael
Occasional Contributor II
Posts: 10
Registered: ‎04-28-2009

Lacp

Now I'm a bit confused. I usually set up my controllers with trunk ports. I am not using a Cisco switch so that config is irrelevant. But I am trunking my controller ports....

int gig 0/0
switchport mode trunk
switchport trunk native vlan xxx
switchport trunk allowed vlan add xxx

So I have planned on mirroring whatever I do in the port-channel on the physical ports just in case.
Guru Elite
Posts: 20,780
Registered: ‎03-29-2007

Re: Lacp

You would configure all of the layer2 trunk commands that you would normally configure under the interface, under the port channel, instead e.g:

config t
interface port-channel 2
switchport mode trunk
switchport trunk native vlan 5
switchport trunk allowed vlans all


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Search Airheads
Showing results for 
Search instead for 
Did you mean: