ArubaOS and Controllers

Reply
Contributor II

Layer 3 setup with OSPF

I am trying to get one of our test controllers to talk to a Cisco router via OSPF. We are looking into this as our current layer 2 setup with two routers, two switches, HSRP and spanning tree is fragile. We want to look at replacing this with two point-to-points to each router via the 2 switches.

What I what to do is have the controller advertise routes for the user vlans, and the routers will advertise a default route.

I've been able to get the controller to advertise the user vlans, however I can't seem to get the router to advertise the default route to the controller.

Anyone know how to get the router to advertise it's default route? I've tried many combinations but none work :(

Router is a Cisco 2821 running 15.0(1)M5
Controller is a SUP2 running 3.4.2.6

Here is my setup so far:

Controller
interface gigabitethernet  2/0
description "GE2/0"
trusted
trusted vlan 1-4094
switchport access vlan 100
!
interface vlan 100
ip address 192.168.0.2 255.255.255.252
ip ospf area 192.168.0.0
!
interface vlan 200
ip address 192.168.200.1 255.255.255.0
!
interface vlan 250
ip address 192.168.250.1 255.255.255.0
operstate up
!
router ospf
router ospf area 192.168.0.0 stub
router ospf redistribute vlan 100-500

(Aruba6000) # show ip route

Codes: C - connected, O - OSPF, R - RIP, S - static
M - mgmt, U - route usable, * - candidate default

Gateway of last resort is Imported from DHCP to network 0.0.0.0 at cost 1
Gateway of last resort is Imported from CELL to network 0.0.0.0 at cost 1
Gateway of last resort is Imported from PPPOE to network 0.0.0.0 at cost 1
C 192.168.0.0 is directly connected, VLAN100
C 192.168.200.0 is directly connected, VLAN200
C 192.168.250.0 is directly connected, VLAN250

(Aruba6000) # show ip ospf debug route

OSPF Route Table
----------------
Dest Mask NextHop Cost DestType PathNum PathType
---- ---- ------- ---- -------- ------- --------
192.168.0.0 255.255.255.252 192.168.0.2 1 NETWORK 1 INTRA_AREA



Cisco Router
interface GigabitEthernet0/1
ip address 192.168.0.1 255.255.255.252
ip nat inside
ip virtual-reassembly
ip ospf priority 10
duplex auto
speed auto
!
router ospf 1
router-id 192.168.0.1
log-adjacency-changes
area 192.168.0.0 stub no-summary
redistribute static
passive-interface default
no passive-interface GigabitEthernet0/1
network 192.168.0.0 0.0.0.255 area 192.168.0.0
default-information originate always metric 30 metric-type 1

router#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is 132.206.35.1 to network 0.0.0.0

S* 0.0.0.0/0 via 132.206.35.1
132.206.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 132.206.35.0/24 is directly connected, GigabitEthernet0/0
L 132.206.35.114/32 is directly connected, GigabitEthernet0/0
132.216.0.0/32 is subnetted, 1 subnets
S 132.216.130.2 via 132.206.35.1, GigabitEthernet0/0
192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.0.0/30 is directly connected, GigabitEthernet0/1
L 192.168.0.1/32 is directly connected, GigabitEthernet0/1
O 192.168.200.0/24 via 192.168.0.2, 00:19:05, GigabitEthernet0/1
O 192.168.250.0/24 via 192.168.0.2, 00:19:05, GigabitEthernet0/1
Contributor II

Re: Layer 3 setup with OSPF

After a bunch of tweaking I got the router to advertise the default route to the controller:

router ospf 1
router-id 192.168.0.1
log-adjacency-changes
area 0.0.0.0 range 192.168.0.0 255.255.255.0
area 192.168.0.0 stub
redistribute static
passive-interface default
no passive-interface GigabitEthernet0/1
network 192.168.0.0 0.0.0.3 area 192.168.0.0
network 192.168.1.0 0.0.0.255 area 0.0.0.0


(Aruba6000) #show ip route

O 0.0.0.0/0 via 192.168.0.1*
O 192.168.1.1/32 via 192.168.0.1*
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: