Reply
Frequent Contributor I

OSPF Routing, 650

Good Evening,
I've been working on making my Aruba 650 controller (aos 6.1.2.2) speak ospf with my cisco routing network (5x3660s running ios 12.4). I've figured most of it out and have route information passing between all of the devices now, however there are two elusive pieces that are avoiding me. Any help would be appreciated.

1) The default gateway on the aruba controller is being imported from dhcp while attached to a cable modem, however the default route is not being propagated through ospf to the cisco routers. I assume that this is because it is a dynamic gateway and not a static route. I have the "router ospf default-information originate always" specified. Any way to make this dynamic gateway propagate?

2) I have several network routes that are destined for ipsec tunnels but these do not propagate either. There doesn't appear to be "router ospf redistribute" commands that would help achieve this. Is this even possible?

I know i can very easily go upstream by one router and put in all the static routes or just one default route, but i was kind of trying to be a purist. =D

the 650 has vlan 200 connected to the 3660 "R5" fa 0/0

650

interface vlan 200
ip address 10.200.0.1 255.255.255.0
ip nat inside
operstate up
ip ospf area 0.0.0.0

ip default-gateway import dhcp 1
ip default-gateway import cell 200
uplink wired priority 220
uplink cellular priority 200
uplink wired vlan 4092
no uplink wired vlan 1
uplink disable
ip route 192.168.25.0 255.255.255.0 ipsec OFTM
ip route 10.0.0.0 255.255.0.0 ipsec OFTM
ip route 10.2.0.0 255.255.0.0 ipsec OFTM
ip route 10.3.0.0 255.255.0.0 ipsec OFTM
ip route 10.100.0.0 255.255.0.0 ipsec OFTM

router ospf
router ospf router-id 10.200.0.1
router ospf default-information originate always
router ospf area 0.0.0.0
router ospf redistribute vlan 10,200,4091-4092


3660


interface FastEthernet0/0
ip address 10.200.0.254 255.255.255.0
ip ospf 100 area 0

router ospf 100
router-id 10.200.200.14
log-adjacency-changes
no auto-cost
redistribute connected
network 10.200.0.0 0.0.0.255 area 0
network 10.200.200.0 0.0.0.255 area 0
network 10.201.0.0 0.0.255.255 area 0

Guru Elite

Re: OSPF Routing, 650

Jim,


1. Please remove then add "router ospf default-information originate always" and see if your default gateway propagates

2. We only propagate ip addresses of VLAN interfaces at this time, so you will not see routes of ipsec tunnels propagated


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Frequent Contributor I

Re: OSPF Routing, 650

Colin,
Thanks for the reply, I'm away from my lab network for a week, so I'll check then.
-Jim
Frequent Contributor I

Re: OSPF Routing, 650

that worked like a champ, although i'm not sure why. Any ideas?


R5_Win7#show ip route | inc Gateway
Gateway of last resort is not set
R5_Win7#



(Jim-650) (config) #no router ospf default-information originate
(Jim-650) (config) #router ospf default-information originate always



R5_Win7#show ip route | inc Gateway
Gateway of last resort is 10.200.0.1 to network 0.0.0.0
R5_Win7#
Guru Elite

Re: OSPF Routing, 650

A bug has been filed for this behavior.


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: