ArubaOS and Controllers

Reply
Contributor I

Use local switch's Internal user Database

This feature was intermittent when trying to use the master internal db from a local. Has anyone tried using this in recent os versions and found it working? As I recall it was supposed to see air in 3.4..
Guru Elite

internal User Database




If you want users to be authenticated by the local switch, you must populate the local switch with those users, manually after turning this on. This feature has been working since 2.5 consistently.



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Contributor I

Re: Use local switch's Internal user Database




Actually I want to turn it off. It has been intermittent in it's use of the master db since the start of disneyworld or some such. At the time it was supposed to work in 3.4.0. I see no reference in the release notes. We previously tested in 3.3.2.10 and had an open ticket with Radhesh Hegd at Aruba. He indicated the 3.4.0 fix.

To be clear we want guest accounts created on the master, and used by all locals.

As an aside, I don't think the redundant master gets anything from the primary master internal db automatically. I'd need to test. (talking to self)

Guru Elite

Local Database


Actually I want to turn it off. It has been intermittent in it's use of the master db since the start of disneyworld or some such. At the time it was supposed to work in 3.4.0. I see no reference in the release notes. We previously tested in 3.3.2.10 and had an open ticket with Radhesh Hegd at Aruba. He indicated the 3.4.0 fix.

To be clear we want guest accounts created on the master, and used by all locals.

As an aside, I don't think the redundant master gets anything from the primary master internal db automatically. I'd need to test. (talking to self)




By default, it works that authentication is sent to the master. To change this you would do this:

config t
aaa authentication-server internal use-local- switch


To change it back:
config t
no aaa authentication-server internal use-local- switch


This command is ONLY executed on the local switch in question, not the master. If you have a redundant master, or master-backup relationship, there is a "database synchronize" parameter that needs to be enabled on the master configuration for this database to be synchronized, ONLY in a master-backup master relationship.


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: