ArubaOS and Controllers

Reply
Occasional Contributor I
Posts: 9
Registered: ‎04-06-2011

Web Authentication Disabled

We have an Aruba 3400 Controller with the last 6.0 OS. We are using captive-portal for authentication. I have one computer that keeps getting an error message after it connects to the network. Instead of the captive portal login screen coming up in the browser, the browser shows a page stating “Web Authentication is disabled”. I have to go into the controller and disconnect them from the network before they are able to reconnect. After I disconnect them, they are able to authenticate through the captive portal page. Does anyone know what is causing this? Thank you for your help.
Guru Elite
Posts: 20,993
Registered: ‎03-29-2007

Re: Web Authentication Disabled




The next time is happens, find out what role the user is in, and then open a support case. To work around it temporarily, find out what role the user is in, and add a Captive Portal Profile to it (configuration> Security> Access Control. Edit and Add a Captive Portal authentication profile to it that matches the one you are using for your current network.



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Aruba Employee
Posts: 664
Registered: ‎04-15-2009

Re: Web Authentication Disabled

Wesley - there was a bug in earlier code that would cause this to happen when a CP user connected to one AP, then went to sleep or hibernate, then reconnected to a different AP. This had to happen within the user idle timeout (5 min by default). I know it is fixed in 5.0.3.3 and 6.1.1.0, but I am not sure about 6.0 code. As Colin said, a support case is the best option.
Occasional Contributor II
Posts: 11
Registered: ‎04-13-2009

Re: Web Authentication Disabled

Hi Wesley,

Same issue here with 6.0.1.2. Is it possible for you to post the outcome of the support case?

Regards,

Johan
Regular Contributor I
Posts: 171
Registered: ‎04-13-2009

Re: Web Authentication Disabled

I also had this issue coming up all the time with 6.0.1.2

Since we upgraded to 6.1.1.0 i have not had any reports of this. But it has only been a few business days. If it happens again, i will update this thread.

-ELiasz
-------------------
ACDX, ACCP, CISSP, CWNA
Regular Contributor I
Posts: 171
Registered: ‎04-13-2009

Re: Web Authentication Disabled

I just got this error again. We are now on 6.1.1.0 and i am connected to a RAP-5WN. I connected to the network, authenticated, opened my ssl VPN and connected Outlooked. I walked away for 5-10 minutes, and when i came back my browser is now giving me Web Authentication is Disabled.

This bug is getting very annoying.
-------------------
ACDX, ACCP, CISSP, CWNA
Regular Contributor I
Posts: 171
Registered: ‎04-13-2009

Re: Web Authentication Disabled

ok, so when i got the Web Authentication is Disabled, it looks like the RAP 3G lost signal, and wifi went off. My Client failed to an internal Guest network with same SSID, and at this point i was put to Web AUth Disabled. Does anyone know why my authentication didnt cary over between then 2 connections?
-------------------
ACDX, ACCP, CISSP, CWNA
Regular Contributor I
Posts: 171
Registered: ‎04-13-2009

Re: Web Authentication Disabled




Hi Colin,

The role i am in when i get this is my post auth role of Guest. If i add that profile to it, wouldnt i get all my users redirected to AP after they authenticate?

-ELiasz

-------------------
ACDX, ACCP, CISSP, CWNA
Guru Elite
Posts: 20,993
Registered: ‎03-29-2007

Re: Web Authentication Disabled


Hi Colin,

The role i am in when i get this is my post auth role of Guest. If i add that profile to it, wouldnt i get all my users redirected to AP after they authenticate?

-ELiasz




Normally we see users that get that when they get placed into the logon role. Please open a case. Do not edit the guest role.


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Regular Contributor I
Posts: 171
Registered: ‎04-13-2009

Re: Web Authentication Disabled

I have had 2 cases open in the past, and have been told then next version will fix this, including being told to upgrade to 6.1.1.0.
I am now at 6.1.1.0 and this issue is still happening. I can open another case, but going through the same stuff for the 3rd time and being told to upgrade is not what im hoping is the solution ;)

-ELiasz
-------------------
ACDX, ACCP, CISSP, CWNA
Search Airheads
Showing results for 
Search instead for 
Did you mean: