ArubaOS and Controllers

Reply
New Contributor
Posts: 3
Registered: ‎08-05-2008

wireless exchange clients

We have a new install of Exchange 2010 upgraded from Exchange 2003. When we were using exchange 2003 we had no problems with clients connecting, sending, receiving mail over a wireless connection. Since the upgrade, clients on our wireless network cannot send attachments! This behavior is true whether the client is using outlook 2003/2007 or even OWA (outlook web access (app)). The clients can connect to their mailboxes, send emails without attachments, and receive emails perfectly fine, the problem only exhibits itself when attempting to send an email with an attachment. While on our wired network, none of these problems exist. Everything else, while on wireless, seems to work fine: i.e. file services, database access, application access, etc.

My best guess is that Microsoft changed the way exchange communicates with clients and our controller is blocking a newly used protocol? or inspecting traffic and killing the attachments?
Occasional Contributor II
Posts: 41
Registered: ‎04-03-2007

Re: wireless exchange clients

When you run the following command from the controller do you see any D's?

# show datapath session table

I would want to first check and see if the authenticated policy is blocking any newly used ports.
New Contributor
Posts: 3
Registered: ‎08-05-2008

Re: wireless exchange clients

no D's, but plenty of C flags on the traffic to our mail server...
Aruba Employee
Posts: 135
Registered: ‎06-18-2007

Re: wireless exchange clients

I have a customer experience Outlook/Exchange issues (not like your case with attachment) over wireless. Exchange reports too manage MAPI connections for the a single user and the user ends up not being able to connect. This only happens on wireless. Haven't found a solution but thought I would point it out so you can check the Exchange to see if it's a MAPI connection issue or not.

If they find a solution for the MAPI connection issue, I'll post it back here.

-Mike
Guru Elite
Posts: 20,581
Registered: ‎03-29-2007

Info

Any more detailed information on that?


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Aruba Employee
Posts: 135
Registered: ‎06-18-2007

Re: wireless exchange clients

Colin,

For my customer the issue is as follows:

Users use Outlook client using MAPI via wireless to connect to Exchange server. Outlook opens several MAPI connections per user and generally Exchange is set to about 30-32 connections per user. These connections SHOULD stay open and it should not exceed the 32 connections per user. However, in situations where you may have a firewall that doesn't have ALG enable, Outlook ends up making a large number of connections to Exchange, eventually causing the client to think a connection cannot be made. Unfortunately, there's no way to clear these connections (at least what I'm told by the Exchange administrators) and the client have to wait for about 60 mins. The timeout value I know can be changed but not recommended as per Microsoft.

I've seen this issue without wireless when Outlook client was traversing a firewall to connect to Exchange. What happened, is that the connections open random ports so the firewall doesn't honor this unless ALG is enabled or you enabled all high-level random ports.

In the case of wireless, I have a feeling Outlook is not getting a fast enough response (MS Protocols are known for this) and Outlook tries to open other MAPI connections thus using up the allowed MAPI connections and causing the user to lose connection to Exchange.

The customer in question with Aruba wireless has a firewall policy that allows ALL traffic so it should work. Do you know if Aruba has any ALG type settings?

-Mike
Frequent Contributor I
Posts: 92
Registered: ‎04-09-2007

Re: wireless exchange clients

I'll be watching this thread as our datacenter upgrades to exchange 2010...
though on our wireless we specifically block MS RPC protocols - so exchange is broken by design ;)

One can tunnel RPC via HTTP to get exchagne connected:
http://technet.microsoft.com/en-us/library/aa996072(EXCHG.65).aspx
(well I hope the functionality continues in exchange 2010)

Doing this can at least provide a datapoint on if the specific MAPI connection is being affected by the controller in any adverse way...
Aruba Employee
Posts: 135
Registered: ‎06-18-2007

Re: wireless exchange clients

So I found out some additional info from the customer.

The issue occurs when the client roam between APs. There are no coverage gaps. Looking at the roaming between APs, the client moves within 1 second. However, Outlook loses connection to Exchange. Outlook is configured in cached mode already.

Any ideas on settings that can be tweaked? Customer contacted Aruba support and was told that the issue is due to a coverage gap, which I can know is not true (coverage gap). Being told that it's a coverage gap issue, raised a ton of questions regarding the design, as expected. :)

Thank you.

-Mike
Search Airheads
Showing results for 
Search instead for 
Did you mean: