Campus Switching and Routing

Reply
Occasional Contributor I
Posts: 5
Registered: ‎01-25-2016

Aruba Controller Captive Portal Redirect not working correctly

Hi Everyone

 

I'm setting up an Aruba Controller for the first time (OAW4030 running 6.4.4.3 version)

The setup is farily basic, only one guest network and nothing else

I'm still in a lab environment so I have no internet access, anyway:

 

- When i connect to the network, most devices (W8, Android, etc) are not redirected to the CP login page. The page only appears if I type an IP Address in the browser (even if the IP Address points to nowhere). If i type an URL nothing happens (except for a Sony Xperia Device that I own, but i wouldn't take it as an example, since if tested with four other android devices and none of them worked)

 

Where am I missing?

 

Thank you very much

 

Regards

 

Guru Elite
Posts: 20,960
Registered: ‎03-29-2007

Re: Aruba Controller Captive Portal Redirect not working correctly

Your client needs a functioning dns server.


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Occasional Contributor I
Posts: 5
Registered: ‎01-25-2016

Re: Aruba Controller Captive Portal Redirect not working correctly

There is no way do make the captive portal work with an IP address like with Cisco WLC?

 

When I do the same configuration in a cisco WLC, there's even a notification popup appearing in the android devices screen telling the client that he needs to authenticate...

Guru Elite
Posts: 20,960
Registered: ‎03-29-2007

Re: Aruba Controller Captive Portal Redirect not working correctly

I am answering the wrong question; I apologize.

 

 You should make sure that the apple-cna-bypass is not checked in the captive portal authentication profile.  http://www.arubanetworks.com/techdocs/ArubaOS_64x_WebHelp/Web_Help_Index.htm#ArubaFrameStyles/1CommandList/aaa_authentication_captive.htm?Highlight=apple-cna-bypass  That checkbox would suppress the automatic Captive Portal Popup for Apple devices.

 

For android devices, a different mechanism is used, but there are certain circumstances where it would not work with regards to captive portal detection.  More details are here:  https://www.chromium.org/chromium-os/chromiumos-design-docs/network-portal-detection.



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Aruba
Posts: 1,287
Registered: ‎08-29-2007

Re: Aruba Controller Captive Portal Redirect not working correctly

[ Edited ]

tnunes wrote:

There is no way do make the captive portal work with an IP address like with Cisco WLC?

 

When I do the same configuration in a cisco WLC, there's even a notification popup appearing in the android devices screen telling the client that he needs to authenticate...


You can put in 1.1.1.1 into the browser and it will redirect to the portal.   [Edit: I am guilty of not reading the original question properly]

 

Once upon a time I had a Raspberry Pi configured as a DNS server that always responded with the same address regardless of the lookup.  Was very handy for testing captive portal when internet links were not connected etc.  You could set something like that up for your lab.


If my post is helpful please give kudos, or mark as solved if it answers your post.

ACCP, ACMP, ACMX #294
mclarke@arubanetworks.com
Search Airheads
Showing results for 
Search instead for 
Did you mean: