Campus Switching and Routing

Reply
New Contributor

Aruba with Cisco trunk issue

I have 2920 sw and using  direct with cisco router 800 series. 

for user we are using cisco switch which is conecting with Aruba 2920 

when making TRUNK its take only one VLAN,i need 3 VLAN working with cisco switch. 

 

 

 

 

Highlighted
Occasional Contributor II

Re: Aruba with Cisco trunk issue

What is your config on both sides?

Jibran Aziz
CCIE (RnS / SP / DC) , ACDX , ACCP , ACMP
New Contributor

Re: Aruba with Cisco trunk issue

Dear check below both sw conf 

when i am trying to internal routing in aruba its not taking only 1 vlan is wee can do remotly access. 

 

2 Trunk also not taking all vlan only 1 vlan taking in aruba.

 

 

 

 

cisco switch conf

__________________

hostname switch0a0a15
ip ssh pubkey-auth
ip telnet server
!
interface vlan 1
ip address 192.168.30.4 255.255.255.0
no ip address dhcp
!
interface vlan 23
name Servers
!
interface vlan 150
name WIRELESS
!
interface gigabitethernet1
switchport mode access
switchport access vlan 150
!
interface gigabitethernet27
switchport trunk allowed vlan add 23,30,150
!
interface gigabitethernet28
switchport trunk allowed vlan add 23,30,150

 

___________________________________________

aruba sw conf

 

Edge-Sw#
Edge-Sw#
Edge-Sw# sh run
 
Running configuration:
 
; hpStack_WB Configuration Editor; Created on release #WB.15.17.0009
; Ver #07:eb.8f.fc.f3.ff.37.2d:89
 
stacking
   member 1 type "J9729A" mac-address e0071b-e2e440
   member 2 type "J9729A" mac-address e0071b-e61700
   member 2 priority 192
   exit
hostname Edge-Sw"
trunk 1/48,2/48 trk1 trunk
trunk 1/46-1/47 trk2 lacp
ip default-gateway 192.168.30.1
ip route 0.0.0.0 0.0.0.0 192.168.30.1
ip routing
snmp-server community "public" unrestricted
oobm
   ip address dhcp-bootp
   member 1
      ip address dhcp-bootp
      exit
   member 2
      ip address dhcp-bootp
      exit
   exit
vlan 1
   name "DEFAULT_VLAN"
   no untagged 1/1-1/10,1/13-1/30,1/38,1/45,2/1,Trk1-Trk2
   untagged
 1/11-1/12,1/31-1/37,1/39-1/44,1/A1-1/A2,1/B1-1/B2,2/2-2/47,2/A1-2/A2,2/B1-2/B2
   no ip address
   exit
vlan 11
   name "Users"
   untagged 1/2,Trk2
   ip address 192.168.11.1 255.255.255.0
   dhcp-server
   exit
vlan 23
   name "Servers"
   untagged 1/4-1/10
   ip address 172.23.23.1 255.255.255.0
   dhcp-server
   exit
vlan 30
   name "Data"
   untagged 1/1,1/3,1/13-1/24,1/38,1/45
   tagged Trk1
   ip address 192.168.30.2 255.255.255.0
   exit
vlan 150
   name "Wireless"
   untagged 1/25-1/30,2/1
   tagged Trk1
   ip address 192.168.150.2 255.255.255.0
   exit
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
dhcp-server pool "Users"
   default-router "192.168.11.1"
   dns-server "199.85.127.19"
   network 192.168.11.0 255.255.255.0
   range 192.168.11.10 192.168.11.200
   exit
dhcp-server pool "severs"
   default-router "172.23.23.1"
   dns-server "199.85.127.19"
   network 172.23.23.0 255.255.255.0
   range 172.23.23.10 172.23.23.200
   exit
dhcp-server enable
Occasional Contributor I

Re: Aruba with Cisco trunk issue

You seem to mix up Cisco VLAN trunking (multiple VLANs on a port) with ArubaOS-switch port trunking (bundling mutiple ports together). The attached PDF file with some examples should help.

Contributor I

Re: Aruba with Cisco trunk issue

Hi,

 

In ArubaOS trunk means link aggregation using LACP.

 

If you want to configure a dot1q port you shoud tag vlans to a port:

 

int 2

 tagged vlan 23

 tagged vlan 30

 tagged vlan 150

 untagged vlan XX (usually you untag the root vlan from the trunk)

*
If it helps please add Kudos
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: