Campus Switching and Routing

Reply
Highlighted
New Contributor

Intervlan routing

Hi,

 

I'm having a issue with getting acces from vlan 11 to vlan 14

the DHCP server is on Vlan 11 and it is suppose to give IP addresses to devices on Vlan 12-14 but i can't get it to work.

Here it the config atm.

 

 

ip route 0.0.0.0 0.0.0.0 172.18.231.1
ip route 172.16.1.14 255.255.255.255 172.18.231.1
ip route 172.16.1.27 255.255.255.255 172.18.231.1
ip route 192.168.1.0 255.255.255.0 172.18.231.1
ip routing
interface 47
name "SRV-IMM"
exit
interface 48
name "DRAYTEK-LAN"
exit
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
no untagged 1-44,47-52
untagged 45-46
no ip address
exit
vlan 11
name "SHIP NET"
untagged 1-34,36-44,47-52
tagged 45-46
ip address 172.18.231.254 255.255.255.0
ip helper-address 172.18.231.20
exit
vlan 12
name "CREW NET"
tagged 45-46,49-50
ip address 172.18.232.254 255.255.255.0
ip helper-address 172.18.231.20
exit
vlan 13
name "CUSTOMER NET"
tagged 45-46,49-50
ip address 172.18.233.254 255.255.255.0
ip helper-address 172.18.231.20
exit
vlan 14
name "MAINT NET"
untagged 35
tagged 45-46,49-50
ip address 172.18.234.254 255.255.255.0
ip helper-address 172.18.231.20
exit
vlan 500
name "WAN NET"
no ip address
exit
primary-vlan 11
management-vlan 11
spanning-tree
spanning-tree mode rapid-pvst
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
no dhcp tr69-acs-url
password manager

 

Best regards Andreas

Re: Intervlan routing

Is it just dhcp-relay that is not working, and have you tested the IP routing by configuring a client with a static IP and default gateway to verify that IP routing is working? Do clients get an IP address?

 

One thing that I found is that on vlan 11:

vlan 11
  name "SHIP NET"
  untagged 1-34,36-44,47-52
  tagged 45-46
  ip address 172.18.231.254 255.255.255.0
  ip helper-address 172.18.231.20

You have an ip helper-address in the same subnet. This should not be done, as the DHCP server should respond directly in that subnet, not via an IP-helper.

 

If it is indeed just a DHCP issue (and removing the helper from vlan 11 does not resolve your issue), you can check the statistics from the dhcp-relay:

dhcp.png

 

--
If you have urgent issues, please contact your Aruba partner or Aruba TAC (click for contact details).
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: