Campus Switching and Routing

Reply
Occasional Contributor I

Network migration to Aruba 2930F 48G PoE+ 4SFP Switches

Hi there, first of all total network newbie here... I have basic knowledge of working with switches at the commandline and most of my experience is basic configuration using web gui interfaces. We are moving to new Aruba switches Aruba 2930F 48G PoE+ 4SFP. I have 3 of these units, one of which will be the core switch (network backbone). Our current setup is as follows; Switch 1 (Core Switch): 3Com 4500 PWR 26-Port Software Version 3Com OS V3.03.00s56 (Product 3C Number: 3CR17571-91) Switch 2: HP 2530-48G-PoEP Switch (J9772A) Switch 3: LanPro LP-SGW2404FP (24 Copper PoE + 4 Fiber Gigabit Managed Switch) My initial plan is to backup the configs from each of the switches and then import them into the new switches. Thusfar I've been able to download the configs from the HP and LanPro switches (the file extensions are pcc and cfg). I am having trouble backing up the config from the 3Com unit despite having setup a TFTP server. Everytime I try to backup the config to the TFTP server it fails saying the switch cannot find the TFTP server address. So a few questions here; 1) How do I backup the entire config for the 3Com switch via TFTP or any other method? I would appreciate any guide available for this function. 2) Is restoring the pcc and cfg files from the LanPro and HP switches enough to fully migrate the full configs from those switches to the new Aruba units? Thank you in advance.
Occasional Contributor I

Re: Network migration to Aruba 2930F 48G PoE+ 4SFP Switches

Ok some progress...

 

I have now managed to import the config from the HP 2530 into the 2930F units. Following some research and a few failed import attempts I discovered I needed to add the switch details/module into the header of the config file. So I added;

 

; JL262A Configuration Editor; Created on release #WC.16.02.0014
; Ver #0f:01.81.b3.ef.7c.59.fc.6b.fb.9f.fc.f3.ff.37.ef:2d

hostname "switchname"
module 1 type jl262a

timesync ntp
time timezone -240
ip default-gateway 10.1.0.6
snmp-server community "switchname" unrestricted
snmp-server contact "AdministratorName"
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-52
   ip address 10.1.0.20 255.255.255.0
   exit

 

The import was successful and I tested PoE, VoIP phone connectivity along with regualr data access which were all successful. As luck would have it I convinced the client  to leave the LanPro switch as is. This switch contains the config for their wifi AP's which are only 11g capable so won't go above 54Mbps. The main reason behind the upgrade was to get the LAN up to 1Gbps. So I suggested we configure the 2nd 2930F exactly the same as the first one and then migrate the non-wifi connections from the LanPro to the 2nd switch. This tidies things up a bit. Having the 100Mps switch on the network isn't a major as their Internet connection is only about 10-12Mbps any way and seen as no other devices (apart from the wifi AP's) will be connecting to the LanPro it should do ok just as is.

 

I had a go at importing the 3Com core switch config into the new 2930F Core switch but that didn't go well at all, there is a big difference in how the 3Com cfg file is written compared to how the HP 2530 pcc file wrtten. So now it's back to the drawing board and more research.

 

Is there any way that one can easily "translate' the 3Com cfg file's "syntax" to a format the 2930F will "understand"?

 

Thanks in advance.

Occasional Contributor I

Re: Network migration to Aruba 2930F 48G PoE+ 4SFP Switches

This is proving to be a very tedious exercise.... I have been trying to figure out what the individual lines mean in the 3Com switch's cfg file and then looking for the associated Aruba command, this is proving to be very difficult. The client is putting pressure on me to get the new switches in place despite me telling them in advance that this was not my area of expertise and that I would make a best effort attempt.

 

So I was wondering if anyone would be able to help translate the attached cfg file so that I can import it into an Aruba 2930F-24G-PoE+-4SFP Switch (JL261A) switch as a *.pcc config file?

 

Thanks in advance and any help would be greatly appreciated.

 

 

New Contributor

Re: Network migration to Aruba 2930F 48G PoE+ 4SFP Switches

Here is a little info to get  you started:

 

Vlan Info <-- 3Com Info

 

 

interface Vlan-interface1
 ip address 10.1.0.13 255.255.255.0 
#
interface Vlan-interface2
 ip address 10.1.1.1 255.255.255.0 

is:

 

vlan 1
name "vlan1"
untagged XX-YY
ip address 10.1.0.13 255.255.255.0
exit
vlan 2
name "VLAN2"
tagged XX-YY
ip address 10.1.1.1 255.255.255.0
exit

 

 

(question: I also see references for QoS for Voice in the config, is this something you wanted in your config? If so check out the following: Advanced Traffic Management Guide HPE. Also you can look at the section called "voice vlans" that might be interesting to you)

======================================================

 

ip route-static 0.0.0.0 0.0.0.0 10.1.0.6 preference 60

is:

ip route 0.0.0.0 0.0.0.0 10.1.0.6  distance 60

 

======================================================

 

 snmp-agent local-engineid 8000002B0024734752006877
 snmp-agent community read public 
 snmp-agent community write private 

is:

 

snmp-server engine-id local 80:00:00:2B:00:24:73:47:52:00:68:77

snmp-server community public restricted 

snmp-server community private unrestricted

 

=======================================================

 

 

Hope this at least points you in the right direction!

 

Thanks

Benny

Occasional Contributor I

Re: Network migration to Aruba 2930F 48G PoE+ 4SFP Switches

Thanks Benny, much appreciated, I did manage to get the static route in the config following some digging around.

 

Yes there is Voice running (on VLAN2) and if I read the config right, there is a some sort of QoS which prioritizes the VoIP traffic. I haven't figured out the commands as yet.

 

I do know that these lines have something to do with telling the switch that any device connected which has a MAC address within this range is a VoIP phone? I still haven't figured out what the actual deny means?

acl number 4999
 rule 0 deny dest 0000-0000-0000 ffff-ffff-ffff

stp-edged port enable refers to spanning tree, so I have enabled this and used "MSTP" mode... from what I've read this is the recommended setting.

 

All I need to do now is figure out what the following means and what the commands are to implement them...

 

acl number 4999
 rule 0 deny dest 0000-0000-0000 ffff-ffff-ffff  - the command starts with access-group but I haven't figured out how to use it as yet.

port link-type hybrid - sets the port type I assume hybrid is a combinatin of port types (access/trunk) not sure at this point.
 port hybrid vlan 2 tagged - any outgoing traffic tagged with vlan 2 remains tagged?
 port hybrid vlan 1 untagged - any outgoing traffic from vlan1 remains untagged/has it's tag removed?
 broadcast-suppression pps 3000 - this has to do with broadcast storm management - anything over 3000 packets per second will be discarded by the switch.
 packet-filter inbound link-group 4999 rule 0 - I think this is some sort of QoS for the Voice VLAN but I'm really not sure.

 

Once I get all the commands sorted, I will move on to indvidual port configuration.

 

Thanks again for the help and insight!

Occasional Contributor I

Re: Network migration to Aruba 2930F 48G PoE+ 4SFP Switches

Ok so made some more progress... man google is earning it's weight in gold!!!

 

So this is what the config file looks like now;

 

; JL261A Configuration Editor; Created on release #WC.16.02.0014
; Ver #0f:01.81.b3.ef.7c.59.fc.6b.fb.9f.fc.f3.ff.37.ef:2d
hostname "CORE-ZEUS"
module 1 type jl261a
timesync sntp
sntp unicast
sntp server priority 1 10.1.0.17
time timezone -240
ip default-gateway 10.1.0.6
ip route 0.0.0.0 0.0.0.0 10.1.0.6 distance 60
snmp-server engine-id local 80:00:00:2B:00:24:73:47:52:00:68:77
snmp-server community public restricted
snmp-server community private unrestricted
snmp-server contact "Administrator"
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-28
   ip address 10.1.0.23 255.255.255.0
   ip igmp
   exit
vlan 2
   name "VoIP"
   ip address 10.1.1.1 255.255.255.0
   ip helper-address 10.1.0.8
   ip helper-address 10.1.0.17
   ip helper-address 10.1.0.18
   ip igmp
   exit
spanning-tree
interface 1-24 broadcast-limit 5

 

The only parts I have not figured out from the original 3Com core switch are;

 

port link-type hybrid - Is this setting the port to "trunk" mode and setting the trunk group to "Trk1"? Also if you have multiple "trunk" mode ports that are using the same VLANs does that mean they should be in the same trunk (Trk1) group?

 

 port hybrid vlan 2 tagged - don't know what the command is for this?
 port hybrid vlan 1 untagged - don't know what the command is for this?

 

acl number 4999
 rule 0 deny dest 0000-0000-0000 ffff-ffff-ffff

 packet-filter inbound link-group 4999 rule 0

Still don't know how to set this up... I have not been able to make heads or tails of the command to use? I have narrowed it down to the following commands in config mode - ip access-list or ip access-group. Running these two commands as is gives me an "Invalid input:" error. I have not been able to figure out what the rest of the command is meant to be.

 

Any advice would be greatly appreciated. It's been quite satisfying figuring all this out but the deadline is fast approaching and I really feel I've almost got it... just need to google more or wait for a guardian network angel to point me in the right direction.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: