LLDP on Aruba Controller

Introduction :

 

ArubaOS 6.4 provides support for Link Layer Discovery Protocol (LLDP) on the controllers to advertise identity information and capabilities to other nodes on the network, and store the information discovered about the neighbors.

Link Layer Discovery Protocol (LLDP), defined in the IEEE 802.1AB standard, is a Layer 2 protocol that allows network devices to advertise their identity and capabilities on a LAN. ArubaOS supports a simple one-way neighbor discovery protocol with periodic transmissions of LLDP PDU.
 
  • LLDP frames are constrained to a local link.
  • LLDP frames are TLV (Type-Length-Value) form.
  • LLDP Multicast address is 01-80-C2-00-00-0E.
LLDP provides support for a set of attributes used to discover neighbor devices. These attributes are referred as TLVs which contain type, length, and value descriptions. LLDP supported devices use TLVs to receive and send information such as configuration information, device capabilities, and device identity to their neighbors.

 

Feature Notes :

 

  1. Inventory-management, and Location TLVs are not currently supported.
  2. Aggregation-management and Power-management TLVs are not supported.
  3. LLDP-MED will be supported in a future release.
  4. SNMP support is currently not available for LLDP MIBs.
  5. LLDP is not supported on the expanded slots and the management port of the M3 controller.
  6. Cisco Discovery Protocol (CDP) proprietary is not supported.
  7. The maximum number of neighbors that can be learnt on the controllers (including all the per port neighbor) is 250.
ArubaOS supports the following optional basic management TLVs which are enabled by default:
 
  • MAC Phy configuration TLV
  • Management address TLV
  • Maximum frame size TLV
  • Port-description TLV
  • Port VLAN ID TLV
  • System capabilities TLV
  • System description TLV
  • System name TLV
  • VLAN name TLV

 

Configuration Steps :

 

You can configure LLDP using the CLI. For detailed information on the LLDP commands, 
 
(host)(config) #interface gigabitethernet <slot/port>
(host)(config-if) #lldp
fast-transmit-counter <1-8>
fast-transmit-interval <1-3600>
med
receive
transmit
transmit-hold <1-100>
transmit-interval <1-3600>

 

 

Answer :

 

(host) #show lldp interface gigabitethernet 1/1
Interface: FE1/1
LLDP Tx: Disabled, LLDP Rx: Disabled
Proprietary Neighbor Discovery: Disabled
LLDP-MED: Disabled
Fast Transmit interval: 1, Fast Transmit message counter: 4
Transmit interval: 30, Transmit hold 4, Hold timer: 120

(host)# show lldp interface
LLDP Interfaces Information
---------------------------
Interface LLDP TX LLDP RX LLDP-MED TX interval Hold Timer
--------- ------- ------- -------- ----------- ----------
GE1/3 Enabled Enabled Enabled 30 120
GE1/4 Enabled Enabled Enabled 30 120

 

 
(host) #show lldp interface gigabitethernet <1/3>
Interface: gigabitethernet0/0/1
LLDP Tx: Enabled, LLDP Rx: Enabled
Proprietary Neighbor Discovery: Disabled
LLDP-MED: Disabled
Fast Transmit interval: 1, Fast Transmit message counter: 4
Transmit interval: 30, Hold timer: 120

(host)#show lldp neighbor
Capability codes: (R)Router, (B)Bridge, (A)Access Point, (P)Phone, (O)Other
LLDP Neighbor Information
-------------------------
Local Intf Chassis ID Capability Remote Intf Expiry-Time (Secs)
--------- ----------- ---------- ----------- ------------------
GE1/3 00:0b:86:6a:25:40 B:R GE0/0/17 105
GE1/4 00:0b:86:6a:25:40 B:R GE0/0/18 105
System name
-----------
Aruba3600
Aruba3600
Number of neighbors: 2

 

(host)# show lldp statistics
LLDP Statistics
---------------
Interface Received Unknow TLVs Malformed Transmitted
--------- -------- ----------- --------- -----------
GE1/3 0 0 0 0
GE1/4 0 0 0 0

(host)# show lldp statistics interface gigabitethernet 1/3
LLDP Statistics
---------------
Interface Received Unknow TLVs Malformed Transmitted
--------- -------- ----------- --------- -----------
gigabitethernet1/3 0 0 0 0
LLDP Statistics
---------------
Interface Received Unknow TLVs Malformed Transmitted
--------- -------- ----------- --------- -----------
gigabitethernet1/3 0 0 0 0

 

Verification :

 

# show lldp interface
#show lldp interface gigabitethernet <slot/port>
#show lldp neighbor
#show lldp neighbor interface gigabitethernet <slot/port> detail
# show lldp statistics
# show lldp statistics interface gigabitethernet 1/3

 

Troubleshooting :

 

Sample Cisco config:
 
lldp run
!
!
!
!
interface Port-channel5
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet1/0/1
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport mode trunk
duplex full
channel-group 5 mode active
!
interface FastEthernet1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 5 mode active


cisco3750(config-if)#do show lldp nei
Capability codes:
    (R) Router, (B) Bridge, (T) Telephone, (C) DOCSIS Cable Device
    (W) WLAN Access Point, (P) Repeater, (S) Station, (O) Other
 
Device ID           Local Intf     Hold-time  Capability      Port ID
Aruba7210           Fa1/0/1        120        B,R             GE0/0/0
Aruba7210           Fa1/0/2        120        B,R             GE0/0/1

 

 

Version History
Revision #:
1 of 1
Last update:
‎07-04-2014 02:07 AM
Updated by:
 
Labels (1)
Contributors
Comments

This is good news. I've been wanting LLDP for a while. Thanks!

Search Airheads
Showing results for 
Search instead for 
Did you mean: 
Is this a frequent problem?

Request an official Aruba knowledge base article to be written by our experts.