Controller Based WLANs

Why do some smartphones device randomly not connect to the wireless on 5GHz? Why do some smarphones connect to one AP but not to another AP on the same network and with the same configuration? What sort of behaviours do you tend to see with devices (Androids/iphones) not probing UNII2/2e,165 channels on 5GHz?

Environment  : Any Aruba OS and Any Aruba Controller/APs.

 

Client connectivity to 5GHz will be random.  Some smartphones will not connect to APs on 5GHz.  Same clients will connect to other APs with same configuration or even connect to the same APs they were not connect to earlier.

 

This depends on the channels supported on 5GHz by the client devices and the channel used by the AP for broadcast.  When ARM selects a channel that clients support, they can connect else they cannot.

 

 

The country code selected in the AP regulatory domain profile determines the support channels and channel-pairs.  One way to allow more clients to connect on the 5GHz is to enable 802.11d so that the country code information is advertised in the beacons sent by the APs, however we must careful as some devices may not support 802.11d and may not associate to the APs.  Another workaround if we have a mix of these smart devices on the network is to turn off the channels not supported by some devices from the AP regulatory domain profile, then more clients can connect to 5GHz. 
 
To enable 802.11d:
# rf dot11a-radio-profile <profile>
# 802.11h ---------------------------------Enables advertisement of 802.11d (Country Information) and 802.11h (TPC or Transmit Power Control) capabilities
# write mem
 
To turn off some channels that ARM can use in 5GHz:
# config term
# ap regulatory-domain profile <APGroup1>
# valid-11a-channel <num>
# valid-11a-40mhz-channel-pair <valid-11a-40mhz-channel-pair>
or 
# no valid-11a-channel <num>
# no valid-11a-40mhz-channel-pair <valid-11a-40mhz-channel-pair>
# write mem
 
Example: The following command configures a regulatory domain profile for APs in the United States and specifies that the channel pair of 36 and 40, is allowed for 40 MHz mode of operation on the 5 GHz frequency band:
 
(Aruba) #config term
(Aruba) (config) #ap regulatory-domain-profile usa1
(Aruba) (config) #country-code US
(Aruba) (config) #valid-11a-40mhz-channel-pair 36-40
(Aruba) (config) #write mem
 
This behaviour can be due to the channels used by the AP to broadcast on 5GHz  and also depends on the channels in 5GHz supported by each device type.  Following are some sample information about a few devices: 
 
Androids don't actively probe DFS channels unless they first hear beacons on the channel they are interested in.  Samsung GS4 doesn't support UNII-3 for instance.
 
Cisco 792x phones don't support Channel 165. 
 
For Mac OS, it depends on the country.  Macbooks are seen to not consistently come up with the same country code and they change based on what they hear.  For example, if Macbook starts out with a country say US, it works fine but then if changes to GB, it will not support UNII-3 and we may see it has problems connecting to the AP that's broadcasting on a Channel in UNII-3.
 
Basically, many devices are not actively probing any DFS channels but they do sit there and listen for beacons.  On the other hand, they can do active probing on UNII-1 and UNII-3 which make them detect the AP faster than UNII2.

As shown above, one way to fix this is by enabling 802.11d on the "a" radio profile or to customize the AP regulatory domain profile and enable channels supported by all clients on the network.
Version History
Revision #:
1 of 1
Last update:
‎07-16-2014 06:08 AM
Updated by:
 
Labels (1)
Contributors
Search Airheads
Showing results for 
Search instead for 
Did you mean: 
Is this a frequent problem?

Request an official Aruba knowledge base article to be written by our experts.