Controller-less WLANs

Enabling "preferred master" on Instant AP (IAP) does not work if "Instant" is broadcast.

Problem:

  WLAN administrator can enforce a particular Instant AP to act as a Master.

Starting from InstantOS version 6.3.1.1-4.0.0.0  we can selectively choose one of the member in the cluster and set it as "Preferred Master".

Provisioning of IAP as a master can be done by using the Instant UI or CLI.

But enabling this option in a specific AP will not take effect if factory default SSID "Instant" is still being broadcasted.



Diagnostics:

Example:

Two APs in cluster (AP1 & AP2) with AP1 initially acting as master. Factory-default SSID "Instant" is seen broadcasted.

 

 

Set "preferred master" to enable for AP-2 and then reboot the specific AP for the changes to take effect.

 

Once the AP reboots and comes up you could see the AP being set to "Init ---> slave" during the boot process and the AP-2 continues to act as slave irrespective of preferred master being set.

To verify that the config is present please execute #show ap-env on AP-2

AP2# show ap-env

Antenna Type:Internal
name:AP2
wifi0_arm_channel:52
wifi0_arm_power:3
wifi1_arm_channel:6
wifi1_arm_power:3
iap_master:1      ---------> this indicates that the preferred master has been set to "enable"
AP2#

 



Solution

To make the specific AP act as preferred master we have to configure a non-factory default SSID so that the "instant" SSID gets removed.

Now go to AP2 --- 'Edit' and enable "preferred master". Reboot the specific AP for changes to take effect.

AP2 comes up as a master AP and then the AP1 reboot itself and joins the cluster as a slave.

 

Version History
Revision #:
3 of 3
Last update:
‎05-28-2016 02:15 AM
Updated by:
 
Labels (1)
Contributors
Search Airheads
Showing results for 
Search instead for 
Did you mean: 
Is this a frequent problem?

Request an official Aruba knowledge base article to be written by our experts.