Controllerless Networks

Reply
Occasional Contributor II
Posts: 32
Registered: ‎09-03-2013

Apple Wi-Fi Sync Bonjour Issue(135 AP)

Hi There,

 

We have an issue whereby we have a 135 AP and would like to use the Wi-Fi sync feature available between iTunes and Apple Devices, I found the AirGroup function within the AP and enabled it, I also found the Bonjour protocol which is required for it to sync which is "_apple-mobdev2._tcp".

 

Under the AirGroup section there is a default profile called "itunes" which enables the "_apple-mobdev._tcp" option and the "allowall" profile which enables the "_apple-mobdev2._tcp" . However after enabling these the iPhone is unable to sync to iTunes(even if I enable all profiles). The iPhone has a section under "Settings > General" called "iTunes Wi-Fi Sync" in which a button becomes activated once it can see the machine on the network, after enabling the profiles in AirGroup the button does become active, however after tapping it, it get's stuck at "Looking for XXXXXX", where "XXXXXX" is the name of the machine.

 

I've connected the 2 devices(Laptop and iPhone) to a standard home style router(which doesn't have any configuration options for Bonjour, so assuming it's enabled by default) and they can sync fine, it's only when connected to the 135 AP's they have the issue.

 

I used the software called "Bonjour Browser" on the laptop running OS X 10.9.1 Mavericks which shows all the Bonjour services it can find and current ones itself is broadcasting, and used the same software on the iPhone(same app is available on the App Store), the iPhone is broadcasting the "_apple-mobdev2._tcp" service however the Mac cannot see it for some reason, have been trying for hours to get it to work but it just wont.

 

At the moment it's just a single Aruba AP 135 on it's own(configured as a virtual controller and as an AP), broadcasting both 2.4Ghz and 5Ghz bands, no special settings adjusted or activated, the AP is running firmware "6.3.1.1-4.0.0.0_40930".

 

Any help would be greatly appreciated.

 

Thanks

Guru Elite
Posts: 21,281
Registered: ‎03-29-2007

Re: Apple Wi-Fi Sync Bonjour Issue(135 AP)

 

Try to turn off (disable)  Airgroup .  Also make sure you have "Drop Broadcast and Multicast" on the Virtual AP profile disabled.

 

See if it works.

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Guru Elite
Posts: 8,643
Registered: ‎09-08-2010

Re: Apple Wi-Fi Sync Bonjour Issue(135 AP)

Can you try manually adding the service ID and enabling it?

 

instant-airgroup-custom.PNG


Tim Cappalli | Aruba Security TME
@timcappalli | timcappalli.me | ACMX #367 / ACCX #480
Occasional Contributor II
Posts: 32
Registered: ‎09-03-2013

Re: Apple Wi-Fi Sync Bonjour Issue(135 AP)

[ Edited ]

Thanks for the replys, i've got it to work now but fear I migh have just added an extra load of traffic onto the network.

 

@cjoseph

 

I wasn't sure at first as when you said turn off Airgroup I thought that would disable the functionality of Bonjour and completely not allow the devices to talk. However I did that and then tried to look for the option "Drop Broadcast and Multicast" but couldn't find it. I thought I remembered seeing it in the AP profile settings(picture below) but couldn't, instead I saw the option "Broadcast filtering" which was set to "enabled", I then set that to "disabled" and viola, a re-launch of itunes and it immediatley saw the iPhone and a second device(iPad) which we set up to sync.

 

@cappalli

 

Earlier today I tried just that but it didn't work, the devices just couldn't see each other, however after getting everything to work using the above just now, I tried it again and it broke it again, enabling just that profile with that service ID stopped the devices from seeing each other, I tried again to enable all profiles but again it didn't work.

 

It seems a bit strange though, as before I turned of "Broadcasting filtering" and Airgroup, it did momentarily work with "Airgroup" enabled and all profiles on, stumped, I eventually found the only difference was that both Mac and iPhone were using the 2.4Ghz band instead of 5Ghz, ofcourse that was only temporary due to where I was when connecting to the AP's, most of the time they all allways use the 5Ghz band.
.


So now i've disabled "Broadcast filtering" and turned off "Airgroup" and all seems to be working fine, however my question now would be that because i've disabled "Broascast filtering", will that add alot of Bonjour traffic onto the network ?, as from what I understand it's a very chatty kind of protocol.

 

The adjustment I made(as well as turning off "Airgroup" is as below):

 

1.jpg

RMB
Occasional Contributor I
Posts: 5
Registered: ‎02-24-2013

Re: Apple Wi-Fi Sync Bonjour Issue(135 AP)

[ Edited ]

Hi,

 

I have this issue too on my IAP-225 accesspoint's.

The only way to get sync working again by disabling the AirGroup feature.

I have firmware 6.3.1.2-4.0.0.3_41784 running on the IAP's.

 

Kind regards,

Rene.

Search Airheads
Showing results for 
Search instead for 
Did you mean: