Controllerless Networks

Reply
Contributor II

Connecting 3 IAPs to S1500-12P to cable modem

Greetings all,

 

I have what might be a simple/stupid issue you might find right away, my issue is that my devices are getting IP addresses from the IAP DHCP depending on the VLAN, but I'm not getting any packets beyond the IAPs/virtual controller.

 

I have three IAPs: one IAP-215 as the VC, and two other IAP-205.

I have three WLANs, each has it's own VLAN networks.

 

I'm able to join each WLAN and the appropriate IP addreses are given to me, but I can't get beyond the IAP network. Am I missing something? I was under the impression the VC could also handle routing.

 

Thanks very much!

Contributor II

Re: Connecting 3 IAPs to S1500-12P to cable modem

Follow up: I changed the IAPs to DHCP themselves and plugged into my existing network. All IAPs were given IPs from an external DHCP but could not ping the gateway that gave the IAPs their IP address. Hmmm...

Valued Contributor II

Re: Connecting 3 IAPs to S1500-12P to cable modem

HI,

 

When you create a WLAN with VC assigned IP, Clients will get IP from VC and VC will NAT the Client traffic by using VC IP address.

 

Please provide more details on this,

1. Which IP assignment option you have selected ?

2. Which DHCP option you have selected in IAP ?

 

If possible share the snap shot of your config so that I can understand and help you on fixing the issue.

Cheers,
Venu Puduchery,
[Is my post helped you ? Give Kudos :) ]
Contributor II

Re: Connecting 3 IAPs to S1500-12P to cable modem

dhcp.jpg

Contributor II

Re: Connecting 3 IAPs to S1500-12P to cable modem

dhcp_2.jpg

Contributor II

Re: Connecting 3 IAPs to S1500-12P to cable modem

Greetings! This setup is going into a coffee shop, and the master IAP VC will be giving out IPs to each WLAN. I know the switch uplink is working since the IAPs are grabbing IPs from a larger test network for themselves.

Contributor II

Re: Connecting 3 IAPs to S1500-12P to cable modem

Still not sure what's going on - I'm guessing it may be some reason why routing isn't working on the devices.

Contributor II

Re: Connecting 3 IAPs to S1500-12P to cable modem

From the documentation:

 

Configuring DHCP Scopes:

Local—In this mode, the Virtual Controller acts as both the DHCP Server and the default gateway. The
configured subnet and the corresponding DHCP scope are independent of subnets configured in other IAP
clusters. The Virtual Controller assigns an IP address from a local subnet and forwards traffic to both
corporate and non-corporate destinations. The network address is translated appropriately and the
packet is forwarded through the IPSec tunnel or through the uplink. This DHCP assignment mode is used in the NAT forwarding mode.
* Local, L2—In this mode, the Virtual Controller acts as a DHCP server and the gateway located outside the IAP.
* Local, L3— This DHCP assignment mode is used with the L3 forwarding mode. In this mode, the Virtual
Controller acts as a DHCP server and the gateway, and assigns an IP address from the local subnet. The IAP routes the packets sent by clients on its uplink. The Local, L3 subnets can access corporate network through the IPsec tunnel. The network address for all client traffic, which is generated in the Local, L3 subnets and destined to the corporate network, is translated at the source with the tunnel inner IP. However, if corporate access to Local, L3 is not required, you can configure ACL rules to deny access.

Contributor II

Re: Connecting 3 IAPs to S1500-12P to cable modem

After all that, I just changed the scopt from "Local,L3" to "Local" and it worked.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: