Controllerless Networks

Reply
Contributor II

Continuous kernel page fault on IAP-115 cluster - Solved?

So Friday afternoon we started out of no where having wireless connectivity issues. Upon much investigation, we found out all of our IAPs (five in cluster, four active, one monitor mode) were crashing due to kernel page fault errors. At the worst of it the IAPs were not staying online for more than five minutes. As people left on Friday, we witnessed them not rebooting anymore.

 

Over the weekend with only few people in the office, it was stable all weekend. Monday morning rolled around and as more people connected, it started happening again.

 

Got back on the phone with Aruba support and their back end team identified the problem being that 802.11k fast roaming was enabled and causing the crash. We disabled 802.11k and rebooted the cluster. Once it came back, I had people connect back up. I think disabling that feature caused the reboot loops to stop! So in case anyone else is seeing this type of problem with kernel page faults for the reboot reason (you can see this running "show version" on the CLI or More>Support then running "AP Version" on one or all of the IAPs will show you the reboot reason), try disabling 802.11k under each of your SSID security settings and reboot your cluster. You may see increased stability.

 

The *weird* thing is, we had been running 802.11k for about 2-3 years before this started happening. We had upgraded the firmware on the cluster to 6.5.2.0 about a month or two ago and have been fine up until Friday. So it was some weird thing that just started happening out of no where and no changes had been made.

New Contributor

Re: Continuous kernel page fault on IAP-115 cluster - Solved?

mcgillicutty thank you so much for taking the time to write this comment.

We had the exact same problem. We have AP103 running in Instant mode and experienced the rebooting as you describe it (every 5-15 minutes).

Furthermore I also had the problem disapear when there are no clients. 

I took one AP home in order to reset it and configure it from scratch but at home it was working just fine and didn't reboot not even once.

Removing 802.11k now seems to have fixed the issue.

We are running the latest current version: 6.5.4.3_61959.

 

Regards.

New Contributor

Re: Continuous kernel page fault on IAP-115 cluster - Solved?

We use IAP 103 with 6.5.4.3 image. We meet same issue.  After we remove the 802.11k, it work fine.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: