Controllerless Networks

Reply
Frequent Contributor I

High ping latency only towards wireless clients

While trying to analyze a different wifi performance problem I built a really small lab consisting of a Aruba 2530-25G-PoE switch, a single IAP-315 (Central managed).

 

Connected to the switch I have Miktotik Firewall that runs the DHCP server, and a Linux Desktop.

 

I then connect a Laptop to the wireless 802.1ac PSK network (5GHz) that broadcasts my local network on the IAP-315.

 

I've configured:

Band Steering Mode: Prefer 5 GHz

Airtime Fairness Mode: Fair Access

ClientMatch: On

80 MHz Support: Off

Background Spectrum Monitoring: On (Both 2,4GHz and 5 GHz)

 

Everything works fine I get good throughput with iperf between my laptop and desktop. But what I really can't understand is:

 

If I ping from the Laptop to the Desktop, I get stready replies around 2-3 ms (as expected).

 

However, if I ping from my Desktop to the Laptop I get much higher and variating rtt:

 

64 bytes from 192.168.88.82: icmp_req=1316 ttl=64 time=21.5 ms
64 bytes from 192.168.88.82: icmp_req=1317 ttl=64 time=52.0 ms
64 bytes from 192.168.88.82: icmp_req=1318 ttl=64 time=82.1 ms
64 bytes from 192.168.88.82: icmp_req=1319 ttl=64 time=111 ms
64 bytes from 192.168.88.82: icmp_req=1320 ttl=64 time=37.6 ms
64 bytes from 192.168.88.82: icmp_req=1321 ttl=64 time=68.4 ms
64 bytes from 192.168.88.82: icmp_req=1322 ttl=64 time=97.3 ms
64 bytes from 192.168.88.82: icmp_req=1323 ttl=64 time=24.4 ms
64 bytes from 192.168.88.82: icmp_req=1324 ttl=64 time=53.7 ms
64 bytes from 192.168.88.82: icmp_req=1325 ttl=64 time=82.3 ms
64 bytes from 192.168.88.82: icmp_req=1326 ttl=64 time=111 ms
64 bytes from 192.168.88.82: icmp_req=1327 ttl=64 time=38.2 ms
64 bytes from 192.168.88.82: icmp_req=1328 ttl=64 time=68.3 ms
64 bytes from 192.168.88.82: icmp_req=1329 ttl=64 time=304 ms
64 bytes from 192.168.88.82: icmp_req=1330 ttl=64 time=332 ms

 

Can anyone explain why I get higher latency pinging in one direction than the other between the exact same two devices?

 

I've tested with a few different laptops, and also testing pinging from the switch and still see the same behavior. I also saw the exact same behavior in a customers network with a similar setup.

 

IAP-315 is running 6.5.0.0-4.3.0.0_56428. In my customers network I tried upgrading their IAP to 6.5.1.0-4.3.1.1_57902. Still the same behavior.

 

 

Frequent Contributor I

Re: High ping latency only towards wireless clients

I could also add that this is my laptop 50cm away from the AP, and no one else using the 5GHz band in the neigbourhood:

a8:bd:27:c0:44:fc# show ap spectrum ap-list
Spectrum AP Table
-----------------
bssid essid spectrum-id chan phy-type signal(dBm) ibss add-time last-seen
----- ----- ----------- ---- -------- ----------- ---- -------- ---------
a8:bd:27:84:4f:d0 MathiasPSK 1 52 80211a-VHT-40 0 no 2017-03-28 18:42:57 2017-03-29 20:31:08
Start:0
Length:1
Total:1
Current Time:2017-03-29 20:31:08
a8:bd:27:c0:44:fc# show ap spectrum interference-power
Interference Power Table
------------------------
Channel Noise Floor(dBm) Max AP Signal(dBm) Max AP SSID Max AP BSSID WiFi ACI(dBm) Max Interference(dBm)
------- ---------------- ------------------ ----------- ------------ ------------- ---------------------
52+ -94 - - - N/A -

 

Guru Elite

Re: High ping latency only towards wireless clients

I would try turning off spectrum.



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Frequent Contributor I

Re: High ping latency only towards wireless clients

I've tried turning off "Background Spectrum Monitoring", but it made no difference.

Frequent Contributor I

Re: High ping latency only towards wireless clients

Found the problem. It was caused by a feature called PSP (Power Save Polling) on the Laptops. This causes the WiFi NIC to not immediately receive all packets sent to it (without a delay).

 

On Windows 10 this feature is only enabled when running on battery. To turn it off also on battery, goto Control Panel -> Power Options -> Advanced -> WiFi Adapter and set it "Maximum Performance".

 

On Linux this feature is even enabled when running with the power cord connected. To disable it run:

 

sudo iwconfig wlan0 power off

 

This solved my problem. My ping:

 

PSP On:

64 bytes from 192.168.88.82: icmp_req=20 ttl=64 time=111 ms
64 bytes from 192.168.88.82: icmp_req=21 ttl=64 time=35.0 ms
64 bytes from 192.168.88.82: icmp_req=22 ttl=64 time=53.2 ms
64 bytes from 192.168.88.82: icmp_req=23 ttl=64 time=75.8 ms
64 bytes from 192.168.88.82: icmp_req=24 ttl=64 time=99.9 ms
64 bytes from 192.168.88.82: icmp_req=25 ttl=64 time=36.6 ms
64 bytes from 192.168.88.82: icmp_req=26 ttl=64 time=42.0 ms
64 bytes from 192.168.88.82: icmp_req=27 ttl=64 time=66.8 ms
64 bytes from 192.168.88.82: icmp_req=28 ttl=64 time=88.7 ms
64 bytes from 192.168.88.82: icmp_req=29 ttl=64 time=157 ms
64 bytes from 192.168.88.82: icmp_req=30 ttl=64 time=31.8 ms
64 bytes from 192.168.88.82: icmp_req=31 ttl=64 time=53.6 ms
64 bytes from 192.168.88.82: icmp_req=32 ttl=64 time=94.3 ms

 

PSP Off:

64 bytes from 192.168.88.82: icmp_req=33 ttl=64 time=3.55 ms
64 bytes from 192.168.88.82: icmp_req=34 ttl=64 time=2.03 ms
64 bytes from 192.168.88.82: icmp_req=35 ttl=64 time=1.47 ms
64 bytes from 192.168.88.82: icmp_req=36 ttl=64 time=1.59 ms
64 bytes from 192.168.88.82: icmp_req=37 ttl=64 time=1.57 ms
64 bytes from 192.168.88.82: icmp_req=38 ttl=64 time=1.56 ms
64 bytes from 192.168.88.82: icmp_req=39 ttl=64 time=1.48 ms
64 bytes from 192.168.88.82: icmp_req=40 ttl=64 time=1.55 ms
64 bytes from 192.168.88.82: icmp_req=41 ttl=64 time=1.71 ms

 

My new MacBook Pro has the same problem, even when running with power cord connected. I've so far been unable to find out how to disable it there.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: