Controllerless Networks

Occasional Contributor I

IAP-105 with Cisco Catalyst 3560 - NO DHCP

I have a frustrating issue with DHCP for my client devices.  We bought an IAP-105 and connected it to a Juniper EX2200 switch in my office, configured it as the master AP for our network, and connected test clients to the AP without problems.  The wireless clients were able to receive IP addresses from our network's DHCP server correctly.  I then took the IAP-105 to the production environment and connected it to the Cisco Catalyst 3560 that was in production.  The IAP powered on, but wireless clients would not get a DHCP -assigned IP.  I tried every setting in the Cisco I could think of to get the DHCP service to function correctly, but I finally gave up and swapped the Juniper switch in its place, which is working perfectly in production.

Now I have the Cisco back in my office, trying to get DHCP to work through the IAP.  I have the switch connected to my network, and my laptop gets a DHCP address correctly when plugged into a Cisco switchport, so it doesn't appear to be an issue with the Cisco switch blocking DHCP somehow.  I can connect to the IAP when plugged into the switchport (hardwired connection), so network connectivity is working between the IAP and the Cisco.  The IAP even detected the master IAP that is in production and joined its network properly.  I just cannot get a DHCP IP address through the IAP when its connected to the Cisco.  Obviously replacing dozens of Cisco Catalyst switches with Juniper units is not an option.  I am hoping someone else might have seen a similar issue, or have some suggestions for resolving this. 

The IAP that is in production on the Juniper switch is working great, but until I can figure out this IAP-Cisco-DHCP problem, I can't really expand the wireless network.

Guru Elite

Re: IAP-105 with Cisco Catalyst 3560 - NO DHCP

The wireless network that you have configured, is it using a vlan that is "Network Assigned" or "Virtual Controller Assigned"?


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Occasional Contributor I

Re: IAP-105 with Cisco Catalyst 3560 - NO DHCP

Under "Client IP & VLAN Assignment", Client IP Assignment is set to "Network Assigned", Client VLAN Assignment is set to "Static".  With these settings, the IAP-105 connected to the Juniper EX2200 switch passes DHCP information between wireless clients and the network DHCP server correctly.

The IAP-105 connected to the Cisco Catalyst 3560 does not, nor did the currently working IAP when it was connected to the Cisco.

Re: IAP-105 with Cisco Catalyst 3560 - NO DHCP

I had a similar problem but with the AP not getting an ip address no matte what i did, it didnt get the address...

But then i tried with another brand switch and worked fine....


If the IAP was in the same vlan of the DHCP server there was no issue, if the IAP was on ANOTHER vlan  adn i set up the ip helper on the core switch to point my dhcp server then it didnt work....


Now i dont know if in cisco exist this but in alcatel which i had the problem solved it, at least on alcatel you needed to put the ip helper forward delay on 0 seconds.  if that exist on teh cisco try that.  Before doing that check which i the default value, in the case of the alcatel is 2, i mean if it doesnt work just get it back to teh default one its using.


-> show ip helper

 Ip helper :   Forward Delay(seconds) = 0,  

Max number of hops     = 5,  

Relay Agent Information            =  Disabled,  

DHCP Snooping Status               =  Disabled  

 DHCP Snooping Bypass Opt82-Check   =  Disabled,  

 DHCP Snooping Opt82 Format  =  Base MAC,  

 DHCP Snooping Opt82 String  =  00:e0:b1:c6:a2:c2,  

DHCP Snooping Binding DB Status    =  Disabled,

  PXE support                        =  Disabled,

Product Manager - Aruba Networks
Alternetworks Corp
Occasional Contributor I

Re: IAP-105 with Cisco Catalyst 3560 - NO DHCP

Also, I can see on my DHCP server logs that the client is sending DHCP requests, and the server receives them.  The DHCP server then offers an IP address to the client's MAC, which is when things apparently fall apart.  Again, a laptop plugged directly into a Cisco switchport gets an IP correctly, so:

Wired client --> Cisco 3560 --> Nortel 8006 Core --> DHCP server


DHCP Server --> Nortel 8006 Core --> Cisco 3560 --> Wired client

Works correctly.


Wireless client --> Aruba IAP-105 --> Cisco 3560 ---> Nortel 8006 Core --> DHCP Server

seems to work, but

DHCP Server --> Nortel 8006 Core --> Cisco 3560 --> Aruba IAP-105 --> Wireless Client

does not.

I have tried multiple settings for the switch port that the IAP-105 is connected to, including all variations on 802.1q trunk.


I will continue to investigate this issue, including connecting a wired switch to the Cisco to eliminate some switch-switch configuration/compatibility issue, and trying another Cisco Catalyst 3560 to eliminate any possible hardware/software problems with this particular switch.

Re: IAP-105 with Cisco Catalyst 3560 - NO DHCP

Did you try the config i mention in my previews post?

You need to run that on the one that is doing the ip helper or got the ip helper config

Product Manager - Aruba Networks
Alternetworks Corp
Occasional Contributor I

Re: IAP-105 with Cisco Catalyst 3560 - NO DHCP

Hello there,

I am having a very similar issue but it's with random devices.  I currently have 3 devices that cannot get a DHCP address from the server (specifically an iPad, iPhone, and Android Phone).  I happen to be using a Cisco ESW 520 POE switch.  DHCP does not seem to be a problem at all when plugging directly into the switch with a laptop. **** I also plugged in a cheap Linksys Access Point on the same switch and it hands out DHCP addresses to those 3 devices without a  problem.  I am working with support on this, and we captured packets on the switch ports as well as the DHCP server.  I never see the DHCP ack hit the DHCP server for those particular devices.  It's almost as if the IAP's are saying give up after there are several other connected hosts on the network and don't pass the DHCP request.  Today I will be swapping the Cisco ESW switch with a Netgear POE switch to see if that makes a difference.


Let me know if anyone has any ideas on resolving this, or if there is just a bug in the IAP firmware.  Basically I can't use these at all in the current state.




Re: IAP-105 with Cisco Catalyst 3560 - NO DHCP


What IAP Code do you have installed ?

Thank you

Victor Fabian
Lead Mobility Architect
Guru Elite

Re: IAP-105 with Cisco Catalyst 3560 - NO DHCP

I have also experienced this behavior with some clients on the latest build, 3.4.

Tim Cappalli | Aruba Security
@timcappalli | | ACMX #367 / ACCX #480
Occasional Contributor I

Re: IAP-105 with Cisco Catalyst 3560 - NO DHCP

ArubaOS (MODEL: 105), Version
Copyright (c) 2002-2013, Aruba Networks, Inc.
Compiled on 2013-06-21 at 00:00:31 PDT (build 38733) by p4build



Search Airheads
Showing results for 
Search instead for 
Did you mean: