Controllerless Networks

Reply
New Contributor

IAP Certificate Issues with ClearPass

I have 2 IAP clusters, one using ClearPass and one that is not. I have uploaded a wildcard cert to both clusters as a CP certificate in the IAP UI. My cluster without ClearPass works great with no certificate errors.

In contrast, my cluster with Clearpass does not appear to work properly and I am not sure how to fix it. A couple of notes on different behavior for each cluster from the client perspective.

- On the cluster without ClearPass, when accessing a guest network with captive portal hosted on IAP, the redirect for the captive portal goes to https://captiveportal-login.domainname.com

- On the cluster with ClearPass, when accessing the guest network with captive portal hosted on Clearpass, the captive portal web page displays correctly however once credentials are entered, the web page redirects to securelogin.arubanetworks.com which fails DNS resolution and the connection dies.

The hostname of my Clearpass is resolvable from the outside without issue.

I am not very well versed on ClearPass but any assistance would be greatly valued.

 

Thanks in advance,

 

Chris

Guru Elite

Re: IAP Certificate Issues with ClearPass

Did you update the login URL in your guest login form in ClearPass to https://captiveportal-login.domainname.com?

Tim Cappalli | Aruba Security
@timcappalli | timcappalli.me | ACMX #367 / ACCX #480
New Contributor

Re: IAP Certificate Issues with ClearPass

Tim, I have not. Could you point me in the direction in CPPM where that value is located? I apologize for my lack of knowledge on CPPM, we had a vendor come in and install it for us and they did little to no knowledge transfer during the process.

Guru Elite

Re: IAP Certificate Issues with ClearPass

Guest > Configuration > Pages > Self-Registrations > (your page) > Edit > NAS Vendor Settings > IP Address

Tim Cappalli | Aruba Security
@timcappalli | timcappalli.me | ACMX #367 / ACCX #480
New Contributor

Re: IAP Certificate Issues with ClearPass

Tim,

Thank you very much, that took care of it. I appreciate the quick response and accurate description of the solution.

 

Have a happy new year!

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: