Controllerless Networks

Reply
Contributor II

IAP Virtual Controller web interface stops working

Last week I noticed after some undetermined amount of time, the web interface for my virtual controller will stop working. When I try to access it, it says the webpage is not available. If I reboot the access point that is the home of the virtual controller, it will start working again but apparently stop working again after some time. I even tried upgrading the APs to the newest 4.1.0.0 firmware last Thursday night, but coming in this morning the interface again is not working. No apparent 'error' in our syslog from the controller either.

 

I would just keep rebooting it, but I really shouldn't have to. People are connected to it so the access point is working fine.

 

edit: I have five IAP-115.

Re: IAP Virtual Controller web interface stops working

how are you accessing it? by IP? by instant. arubanetworks.com?

have you tried going to the AP IP that's the acting VC. can you ssh into the VC?

does the VC ping?

you're best bet is probably open a TAC case so they can get to the bottom of this
Pasquale Monardo | Senior Network Solutions Consultant
ACDX #420 | ACMP
[If you found my post helpful, please give kudos!]
Contributor II

Re: IAP Virtual Controller web interface stops working

By IP. Local management.

 

The VC IP does ping. SSH brings back no reply when I try to connect, though I am pretty sure it did that before I started having problems with the web interface.

 

Edit: I've also opened TAC issues in the past and gotten pretty poor support. I ended up finding solutions to my problems with a deep Google search after it took them a week to answer me. So I figured I would try here first.

Re: IAP Virtual Controller web interface stops working

Is your VC ip different from the IAP itself?  I know from experience from when a customer forgot to exclude the VC ip from the dhcp and one of the IAPs took that address, things went a bit wonky.....similar to the symptoms you describe.


If my post is helpful please give kudos, or mark as solved if it answers your post.

ACCP, ACMP, ACMX #294
mclarke@arubanetworks.com
Contributor II

Re: IAP Virtual Controller web interface stops working

Nope. All IAP are static assigned. VC is .2 on a /24, IAPs are .248-252. DHCP range is .100-229

 

Thanks for the reply.

 

Opened a case with Aruba support. Got a few initial replies, but now it's been days since the last reply. =\

Occasional Contributor II

Re: IAP Virtual Controller web interface stops working

I'm having the same issue with Instant AP 103's. VC is on the same subet at the other instants but fails to keep a stable connection on the GUI.

 

Please let me know if you found a solution. 

Contributor II

Re: IAP Virtual Controller web interface stops working

No solution yet. The GUI was working yesterday afternoon during a meeting, but then this morning found it to not be working again. 

 

Support has been no help thus far as usual.

Super Contributor I

Re: IAP Virtual Controller web interface stops working

How many IAPs in that cluster and what is the user count like?

Normal Guy
Contributor II

Re: IAP Virtual Controller web interface stops working

Five IAPs. Right now We have around 20 client machines and 20 mobile devices.

 

I just found out something interesting though...

 

I noticed that yesterday in my meeting it started working, which is on the other side of the office. So if I roam to another IAP that is NOT the master running the virtual controller, I can connect to the Web GUI. I just tested this with another laptop of mine. I walked to the other side of the office and can access the Web GUI while roaming to another AP. My two other machines connected to the master are still unable to load the Web UI.

 

Neat.

 

My first thought was access list, but looking at my configuration I don't see much access control. Mostly the only access control I have is setting VLANs for specific users authenticating via RADIUS. The management control wasn't even enabled. I just turned it on to see if it made a difference but it didn't. I'd think any ACLs I do have in place would be in place across all of the IAPs though.

Occasional Contributor II

Re: IAP Virtual Controller web interface stops working

In my situation the IAPs have been deployed in to different locations (remote small warehouses) with 3-5 IAP’s (103’s).

 

We have the virtual master controller IP set as a static. When I loss connection or becomes unstable to the static address, I can still reach the GUI from one of other AP’s that have a DHCP address. I have jump from on AP to AP to find one that finally responds and loads properly.

 

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: