Controllerless Networks

Reply
New Contributor

IAP & AppleTV Remote APP Issues

Good Morning,

 

My first post & I'm also new so please be nice to me :-)

 

I'm at a complete lost when it comes to why my AppleTV remote app doesn't seem to work but AirPlay works without issue everytime. I open the remote app and it tells me it can't find the AppleTV. I've comfirmed network settings and both devices are on the same subnet. Now I've done as much research as I can but I've come up empty handed and could use a fresh pair of eyes. I'm pretty sure this is something silly stupid or at least I hope that is the case but we shall see. I figured resolving this would also resolve why my Control4 Express programing app doesn't automatically detect my C4 controller that is also on the same subnet. Just like the AppleTV my phone detects the C4 AirPlay device and I can stream to it without issue. Here are some screenshots.

IAP Security Roles SettingsIAP AirGroup SettingsIAP Broadcast-Multicast Settings

 

Any additional information needed please ask. I'm lost and could use some help. If it helps knowing I am using two IAP-115s and running firmware 6.5.0.3-4.3.0.3_58594

 

Thank you

Aruba Employee

Re: IAP & AppleTV Remote APP Issues

Hi Johnathan,

 

If all the devices are in the same vlan , you do not have to enable Airgroup unless you are changing broadcast filtering setting to ARP/ALL.

 

As per the screenshot, broadcast filtering is set to off.

 

Please disable Airgroup (all the 3 knobs under Airgroup) & verify if this works.

New Contributor

Re: IAP & AppleTV Remote APP Issues

 

 

Aruba Employee

Re: IAP & AppleTV Remote APP Issues

Hi Johnathan,

 

The steps I mentioned earlier helps in concluding that enabling Airgroup was causing the issues on your setup.

 

This is due to the fact that by default it only recognizes & works with handful of Bonjour services like Airplay, Airprint, Googlecast etc.

 

In case you want to use/discover the devices across vlans/subnets, we need to make use of Airgroup.

 

Please try the following :

 

1. Enable Airgroup.

2. Log in to CLI of IAP & run the following commands while you are trying to use the remoteapp

 

show airgroup blocked-service-id

 

Ideally we should see the service id's used by the remoteapp which is being blocked.

 

3. Copy the service ID & create on new service option under Airgroup.

 

You can add the service id's under that service & enable it.

 

Then try to check if the discovery is working fine.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: