Controllerless Networks

Reply
Occasional Contributor II

Roaming and connection problems with Motorola/Symbol Scanners (MC3xxx)

I trying to replace a standalone wireless network (mixed vendors, most of them is SOHO device) to Aruba Instant. The smartphones, tablets, laptops works fine, if I walk around the warehouse (0 ping packet loss during roaming, rarely 1 max), but the HandScans works very poor (maybe works better with the standalone SOHO network, and it's sad)

Now I tried to modelling the network (separated, no other devices, but the gateway), now testing with 3 piece of IAP-103's in my office (evenly distributed over a long corridor). The problem still exist, many packet lost during roaming, but my laptop/smartfone works fine, 0 packet loss.
IAP-103's running the most recent gen.av. FW: 6.4.2.6-4.1.1.13_54918

My test: connect to AP1, and walk around AP1-->AP2-->AP3. Some packet lost during roaming (about 30-35), and when I arrived near AP3, it's stabilized. After then I tried to walk back (AP3-->AP2-->AP1) at the same way, but that was disastrous. After left from AP3's range the connection was dropped, and recovered after 2-3 (!) minutes, this result about 250 ping packet loss. But it is particularly worrying that finally the HandScan placed directly next to the AP1 and the connection didn't recovered immediately, but only after about 1 minute.

I tried to change lower the power values, but nothing seems to change.

I tried it on our company guest network (Cisco WLC2504, AIR-CAP1602I-E APs), and the HandScanner works fine (maximum 1, but usually 0 ping packet drop during roaming), so I think so the Instant network is needed to configured, it's not the HandScans fault.

Used HandScanners:
Motorola MC3090
Motorola MC3190
Symbol (Motorola) MC3200

Thanks!

Guru Elite

Re: Roaming and connection problems with Motorola/Symbol Scanners (MC3xxx)

What is the transmit power of your access points on the production floor?

Do you have broadcast filtering enabled on that SSID?  

How far apart and how up are the access points mounted?

 

******************
Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.
******************
Occasional Contributor II

Re: Roaming and connection problems with Motorola/Symbol Scanners (MC3xxx)

I moved to band A, scanners was set to use only 5G, I changed the transmit power min/max values and the modulation rates for that wlan profile, now it's much better, only 2 ping packet drops during roaming.

 

This experiences with the modelled network in my office, tomorrow I will try these settings on the production network at our customer site. That was a warehouse, and the APs mounted horizontaly approximately 5-6 meters high.

 

The broadcast filtering is a good idea, I will try it also tomorrow.

 

Should I consider any other settings for the RF, to get it better?

 

Thanks!

Guru Elite

Re: Roaming and connection problems with Motorola/Symbol Scanners (MC3xxx)

Two ping drops is desirable and about average.  You could have interference on the 2.4ghz band.  If you use 5ghz it is preferable.

******************
Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.
******************
New Contributor

Re: Roaming and connection problems with Motorola/Symbol Scanners (MC3xxx)

Hi @ All,

I had the same issues the days.

One of our customers change his devices from Symbol MC9090 to Zebra TC8000.

Since them, there was no day without trouble

 

1. Limit the band for the used SSID to 2.4 GHz (AP & Device)

    There is no need to use 5 GHz, lower distance, more noise.

    The only one is the higher speed … no need for MDE.

 

2. Limit the bandwidth to 1 – 2 MBit, the device should only connect over 11b. (AP)

 

3. Use only channel 1,6,11 for the 2.4 GHz on the AP.

    If possible don’t use channel negotiation, setup the APs to use a fix channel.

    Also, setup the devices to use only these three channels.

 

4. Don’t use automatic transmit power control.

    Never use more than 20 dBm inclusive antenna.

    My best experience is ~ 18 dBm. Use external antennas if possible.

 

5. Disable 802.11r, 802.11k, 802.11v on the used SSID.

 

6. Disable any WiFi power management on the Device (always on).

 

7. Update the Devices to the latest firmware.

 

Specially for Zebra Devices with Android OS, there is another option to make special WiFi-Setting.

See Link below.

http://techdocs.zebra.com/mx/wif

 

Best regards from Germany Alexander

 

P.S. The Zebra TC8000 use only these four 5GHz channels, 36, 40, 44, 48, per default, the rest is not enable. ☹

P.S.P.S. These tricks also works for roaming problems with iOS and other android smartphones. :-) 

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: