Controllerless Networks

Reply
Highlighted
Occasional Contributor I

"Another upgrade is in progress" when trying to upgrade IAP-215

I have a brand new deployment of 13 IAP-215's running 6.4.2.0-4.1.1.0_46028.  Anytime I try to do a firmware update I get the message, "Another upgrade is in progress"

 

Even if I reboot all the AP's in the VC, I still get the error.

Re: "Another upgrade is in progress" when trying to upgrade IAP-215

We're they all the same version when you built the cluster?

If you take just 1 IAP and try to upgrade it what happens?
Have you looked through the system logs to see if there is something going on?
Pasquale Monardo | Senior Network Solutions Consultant
ACDX #420 | ACMP
[If you found my post helpful, please give kudos!]
Valued Contributor II

Re: "Another upgrade is in progress" when trying to upgrade IAP-215

Hi friend,

 

Can you clarify couple of things here,

1. Is it working setup ? ( in production)

2. Are these managed by Airwave or central ?

 

please clarify the above. also share the out put of "show log system" we can fix the issue.

Cheers,
Venu Puduchery,
[Is my post helped you ? Give Kudos :) ]
Occasional Contributor I

Re: "Another upgrade is in progress" when trying to upgrade IAP-215

I saw nothing the system logs whatsoever. However, I was able to resolve this by starting over.  

 

I powered off all the radios but one.  Factory reset it and started from scratch.  From there everything worked fine after bringing the others up.

 

Thanks for the suggestions.

Re: "Another upgrade is in progress" when trying to upgrade IAP-215

I've the same problem but i cannot shutdown all the other aps to solve this issue (i'm in a critical production environment).

 

We've have an hibrid 205, 215 models with virtual controller (without airwave or arubacentral). Now we've the firmware 6.5.0.0-4.3.0.1_57133 and we have tried to upgrade to 6.5.1.0-4.3.1.2_58595, the output is "upgrade cannot proceed because of another upgrade in progress"

 

With "show upgrade" command, the output is "upgrade in progress: no"

status is image-ok in every ap

 

I think that is a bug...

 

Any idea?  thanks

 

Re: "Another upgrade is in progress" when trying to upgrade IAP-215

I've seen that before, your best bet and fastest way to fix this is to separate the clusters, upgrade them separately and join them back.

Think of the upgrade being "stuck". One of your mixed model APs is not fully upgraded.

If you know the IP address of each IAP, you can ssh into each of them and type the following:

show version #which version the AP is on
show image version #which version each partition has (see if your AP has been pushed the correct firmware)
upgrade-image (then hit tab), you will see:

* upgrade-image
* upgrade-image2
* upgrade-image2-no-reboot
* upgrade-image2-no-switch-partition-reboot

Try upgrading to the correct image, if there using the command above, if not, do the first step.
Pasquale Monardo | Senior Network Solutions Consultant
ACDX #420 | ACMP
[If you found my post helpful, please give kudos!]
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: