Data Center

Reply
New Contributor

Aruba 2930F dhcp relay

I have question about dhcp relay on aruba 2930F

My config:

 

hostname "Aruba-01"
module 1 type jl261a
console idle-timeout 1800
console idle-timeout serial-usb 1800
dhcp-relay option 82 replace validate
trunk 23-24 trk1 lacp
gvrp
password minimum-length 8
timesync sntp
sntp unicast
sntp server priority 1 10.10.0.53
time timezone 7
ip default-gateway 10.10.0.1
ip dns server-address priority 1 10.10.0.53
ip route 0.0.0.0 0.0.0.0 10.10.0.1
ip route 10.10.0.0 255.255.0.0 10.10.0.1
ip route 10.10.15.0 255.255.255.0 vlan 10
ip routing
interface 1
name "To Router"
exit
interface 12
disable
exit
interface 13
disable
exit
interface 14
disable
exit
interface 15
disable
exit
interface 16
disable
exit
interface 17
disable
exit
interface 18
disable
exit
interface 19
disable
exit
interface 20
disable
exit
interface 21
disable
exit
interface 22
disable
exit
interface 23
name "Trunk LACP to Switch Trk1"
exit
interface 24
name "Trunk LACP to Switch Trk1"
exit
interface 25
disable
exit
interface 26
disable
exit
interface 27
disable
exit
interface 28
disable
exit
vlan 1
name "DEFAULT_VLAN"
untagged 1-4,Trk1
tagged 5-22,25-28
ip address 10.10.0.254 255.255.255.0
ip bootp-gateway 10.10.0.1
ip helper-address 10.10.0.69
exit
vlan 2
name "2_DigMarketing"
tagged Trk1
no ip address
ip helper-address 10.10.0.69
exit
vlan 3
name "4_CS"
tagged Trk1
no ip address
ip helper-address 10.10.0.69
exit
vlan 5
name "5_SpecialProject"
tagged Trk1
no ip address
ip helper-address 10.10.0.69
exit
vlan 6
name "6_TechTeam"
tagged Trk1
no ip address
ip helper-address 10.10.0.69
exit
vlan 9
name "9_DevOps"
tagged Trk1
no ip address
ip helper-address 10.10.0.69
exit
vlan 10
name "10_Services(Temp)"
untagged 11
tagged Trk1
ip address 10.10.15.1 255.255.255.0
ip helper-address 10.10.0.69
exit
spanning-tree
spanning-tree Trk1 priority 4
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
device-profile name "default-ap-profile"
cos 0
exit
device-profile type "aruba-ap"
enable
exit
activate provision disable
password manager
password operator

 

All of Vlan interface will configure as relay-dhcp to IP 10.10.0.9 on Vlan1

But client still not receive dhcp from server, but if client setup static IP its normal (test on vlan 10)

Please advise configuration for my configuration.

Thanks

 

 

 

 

 

New Contributor

Re: Aruba 2930F dhcp relay

Hi,

why use a helper-address  on VLAN1

the DHCP Server seems to be on VLAN 1 ?
There is no reason to do this, please delete this entry in vlan 1

using no ip helper-address 10.10.0.69 in vlan 1

 

ip bootp-gateway 10.10.0.1 like the same.

 

and try again.

 

best regards

Peter


vlan 1
name "DEFAULT_VLAN"
untagged 1-4,Trk1
tagged 5-22,25-28
ip address 10.10.0.254 255.255.255.0
ip bootp-gateway 10.10.0.1
ip helper-address 10.10.0.69
exit

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: