Foro en Español

Reply
Contributor I
Posts: 29
Registered: ‎10-06-2015

IAP – portal cautivo con asignación estática de vlan al cliente no se muestra

 

Buenas,

 

Tengo dos IAP corriendo release 6.4.2.0-4.1.1 con configuración de acceso guest con portal cautivo con asignación estática de VLAN al cliente (VLAN GUEST ) y este no se muestra.

 

El controlador virtual sólo tiene IP en la VLAN GESTION, el cliente se conecta a la red y obtiene IP válida con DNS públicos, pero la redirección al portal cautivo “securelogin.arubanetworks.com” falla y el portal no se muestra.

 

El SSID de guest no tiene el acceso restringido a ninguna red, y entre las VLAN GUEST y la VLAN GESTION del controlador virtual no hay ningún tipo de filtro aplicado.

 

¿Qué puede estar fallando?¿qué falta por configurar?¿ideas?

 

Muchas gracias,

 

EF

Moderator
Posts: 867
Registered: ‎07-29-2010

Re: IAP – portal cautivo con asignación estática de vlan al cliente no se muestra

Hola

 

Supongo que se tratará de un portal externo, ¿no? Si fuese así, asegurate de que el rol de pre-logon permite acceder al portal externo, y que el usuario tiene acceso a ese portal y a los servidores de dns cuando está en el rol previo. Asegurate también de que exista conectividad desde la red de invitados al portal externo.

 

saludos

Samuel Pérez
ACMP, ACCP, ACDX#100

---

If I answerd your question, please click on "Accept as Solution".
If you find this post useful, give me kudos for it ;)
Contributor I
Posts: 29
Registered: ‎10-06-2015

Re: IAP – portal cautivo con asignación estática de vlan al cliente no se muestra

Hola,

 

se trata del portal interno.

 

Gracias por la respuesta.

 

EF

Moderator
Posts: 867
Registered: ‎07-29-2010

Re: IAP – portal cautivo con asignación estática de vlan al cliente no se muestra

Un motivo bastante común para que no se muestre el portal es que el usuario no llegue a lanzar un HTTP GET, típicamente por no ser capaz de resolver el nombre de la URL en cuestión. Intenta ir a alguna página por nombre para ver si te funciona.

Samuel Pérez
ACMP, ACCP, ACDX#100

---

If I answerd your question, please click on "Accept as Solution".
If you find this post useful, give me kudos for it ;)
Contributor I
Posts: 29
Registered: ‎10-06-2015

Re: IAP – portal cautivo con asignación estática de vlan al cliente no se muestra

El usuario obtiene IP y DNS (públicos) y es capaz de resolver nombres, pero el problema es que no es capaz de resolver “securelogin.arubanetworks.com” ya que el servidor DNS responde con un “no such name”

 

Sin embargo si en vez de asignar al cliente en el SSID la VLAN de forma estática se usa la opción “virtual controller managed” la resolución de ese nombre si se hace.

 

Es como si el controlador virtual no pudiera capturar esa petición de DNS para ponerle una de sus IPs.

 

¿En la VLAN de GUEST debe tener IP en controlador? Ya que la única IP que tiene es la de la VLAN de GESTION.

 

Gracias!!!

 

EF

Moderator
Posts: 867
Registered: ‎07-29-2010

Re: IAP – portal cautivo con asignación estática de vlan al cliente no se muestra

Tal como está te debería funcionar, pero no tengo claro que esa versión de SW te valga. Actualiza el AP a la versión 4.2.x (la 4.2.1.0 la tengo en mi maqueta y funciona perfectamente) y vuelve a hacer la prueba.

 

Saludos

Samuel Pérez
ACMP, ACCP, ACDX#100

---

If I answerd your question, please click on "Accept as Solution".
If you find this post useful, give me kudos for it ;)
Contributor I
Posts: 29
Registered: ‎10-06-2015

Re: IAP – portal cautivo con asignación estática de vlan al cliente no se muestra

Buenas,

 

he probado con:

 

- ArubaInstant_Centaurus_6.4.3.1-4.2.0.1_51844

- ArubaInstant_Centaurus_6.4.3.4-4.2.1.1_53072

 

Y el mismo efecto, tengo un caos de soporte, ya os comentaré el resultado.

 

Gracias,

 

EF

Contributor I
Posts: 29
Registered: ‎10-06-2015

Re: IAP – portal cautivo con asignación estática de vlan al cliente no se muestra

 Otro dato, el virtual controller está formado por dos APs, si el cliente está conectado al AP que tiene el rol de master, funciona, hace el capture y muestra el portal, si te conectas al AP que es slave, te hace el redirect pero el portal no se muestra.

 

saludos,

 

 

Moderator
Posts: 867
Registered: ‎07-29-2010

Re: IAP – portal cautivo con asignación estática de vlan al cliente no se muestra

Asegurate de que tienes los puertos del switch en modo trunk y que la VLAN de invitados está extendida entre ambos AP.

 

Saludos

Samuel Pérez
ACMP, ACCP, ACDX#100

---

If I answerd your question, please click on "Accept as Solution".
If you find this post useful, give me kudos for it ;)
Contributor I
Posts: 29
Registered: ‎10-06-2015

Re: IAP – portal cautivo con asignación estática de vlan al cliente no se muestra

Ese no es el problema ,ya he realizado varias pruebas con varias versiones e incluso cambiando el modelo de IAP; dos 225, dos 205, 225 con un 205, y el resultado siempre es el mismo, los cliente conectados al IAP con rol master ven el portal cautivo, los conectados al slave no (o sólo lo ven en rarísimas ocasiones).

 

Lo que veo con un whireshark en un cliente conectado al IAP slave, es que cuando recibe la respuesta del servidor de DNS que tenga en esa red para el site securelogin.arubanetworks.con el virtual controller no la intercepta poniendo la IP del controlador, y en consecuencia el cliente no llega.

Search Airheads
Showing results for 
Search instead for 
Did you mean: