Forum Français

Reply
Occasional Contributor I

Microsoft NPS / Problème authentification EAP-TLS

Bonjour à la communauté,

 

J'aimerai vous faire partager un problème que nous avons rencontré récemment sur l'installation d'un serveur Microsoft NPS sous Windows 2012 Server R2.

 

Ce problème est davantage spécifique à l'environnement Windows mais NPS est régulièrement utilisé pour la mise en place d'une authentification 802.1x avec des matériels HPE ARUBA.

 

Il s'agit ici d'un problème qui survient lorsque l'on désire mettre en place une authentification par le biais d'un certificat numérique (EAP-TLS).

 

Depuis sa publication cet été, la mise à jour facultative (KB4025335), si elle est installée sur votre serveur où est configuré le role NPS, empêche l'authentification par certificat de fonctionner. Ceci a pour conséquence de ne plus permettre aux utilisateurs de se connecter avec cette méthode d'authentification.

 

Je vous joins ci-dessous le lien Microsoft qui y fait référence :

https://support.microsoft.com/fr-lu/help/4025335/windows-8-1-windows-server-2012-r2-update-kb4025335

 

Frédéric MALADRI
SCC
Aruba Employee

Re: Microsoft NPS / Problème authentification EAP-TLS

Etrange...

En lisant le détail du correctif, je ne vois pas très bien ce qui pourrait causer ce comportement.

J'ai en parallèle surfé les différentes knowledge bases chez nous et personne ne semble se plaindre du KB4025335.

 

Mais peut être n'a t il pas été encore massivement déployé.

Tu as vu ce comportement sur plusieurs installations ?

S.

 

Occasional Contributor I

Re: Microsoft NPS / Problème authentification EAP-TLS

Bonjour,

 

Je n'ai pas encore rencontré ce problème chez un client; uniquement en LAB que j'ai monté très récemment et qui comprenait les "briques" suivantes :

- 1 WINDOWS SERVER 2012 R2 avec les rôles :

  •  NPS
  •  AD CS
  •  AD DS

- 1 IAP 205-H

 

J'ai testé l'association de plusieurs postes sur un SSID 802.1X :

  •  Un poste sous WINDOWS 7
  •  Un poste sous WINDOWS 10

 

A chaque fois que j'ai tenté de me connecter sans modifier cette clef de registre, la tentative de connexion fut un échec. Dès la modification de la clef en suivant les directives de Microsoft, cela a fonctionné.

 

Ma configuration NPS était simple. Si besoin, je peux la fournir. J'ai voulu créer ce post afin d'aider les personnes qui viendraient à rencontrer le même problème. C'est peut-être un faux problème.

 

Frédéric MALADRI
SCC
Regular Contributor II

Re: Microsoft NPS / Problème authentification EAP-TLS

Bonjour Fred,

 

Ce n'est pas en rapport avec le changement dans TLS ? (il faut être compatible avec TLS 1.2...)

ACMP 6.4 / ACMX #107 / ACCP 6.5
Occasional Contributor I

Re: Microsoft NPS / Problème authentification EAP-TLS


alagoutte wrote:

Bonjour Fred,

 

Ce n'est pas en rapport avec le changement dans TLS ? (il faut être compatible avec TLS 1.2...)


Bonjour Alexis,

 

Franchement je ne saurai pas dire. Comment pourrais-je m'en assurer ? Une modification de paramétrage sur le poste ? Sur le serveur ?

 

En tout cas, pour répondre à Serge sur son post, aujourd'hui nous avons rencontré ce problème chez un de nos clients. En appliquant ce "workaround", nous avons pu débloquer la situation.

 

Comme ce problème est récent (il date de fin Juillet de cette année), on risque de le rencontrer sur d'autres installations.

 

Frédéric MALADRI
SCC
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: