Monitoring, Management & Location Tracking

Airwave on Hyper V looses network connectivity

I have installed the Airwave software on Hyper V following the Installation guide. The server works fine but looses network connectivity in sometime. Rebooting helps

 

Environment : This applies to all versions of Airwave.

 

The network services will be down causing the server to loose the network connectivity. We can reboot or restart network services to make it work.

 

Airwave is supposed to work with the Legacy network driver, but due to some know issues on Hyper V we face issues with running Airwave with legacy network adapter. The details are documented here .

We have seen HyperV instances mapped with  2 network adapters ( Legacy and standard) while they have only ETH0 configured on the server.

This also causes connectivity issues.

 

 

Following the below steps will help the server not to run into the above issue again.

1: Disable IPV6 on the server.
 
Add the following lines under /etc/vsftpd /vsftpd.conf to disable ipv6.
isolate=NO
isolate_network=NO

 
2: Remove the file “70-persistent-net.rule”. This contains the MAC/Interface mapping which is updated when the server reboots.
 
# rm –rf /etc/udev/rules.d/70-persistent-net.rules
# init 0
 
 
3: Remove the legacy interface from the Instance and add a static MAC on the standard network adapter ( from the Hyper V WebUI) and boot the server.
 
4: Once the server comes online, the MAC was properly would be  updated in the  “70-persistent-net.rule”.Please make sure that the same MAC is also present in the ETH0 config file.
 
Sample Content of 70-persistent-net.rule” file post reboot.
 
# cat /etc/udev/rules.d/70-persistent-net.rules
 
# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.
 
# PCI device 0x8086:0x100e (e1000)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="08:00:27:fe:c1:03", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
Sample content of /etc/sysconfig/network-scripts/ifcfg-eth0
#cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=none
IPV6INIT=no
NM_CONTROLLED=no
ONBOOT=yes
IPADDR=10.17.164.92
NETMASK=255.255.255.0
GATEWAY=10.17.164.254
HWADDR=08:00:27:fe:c1:03
DISABLED - 1!!

Version History
Revision #:
1 of 1
Last update:
‎04-08-2015 06:16 AM
Updated by:
 
Labels (1)
Contributors
Comments
funscott

we are running a 2012 r2 hyperv cluster. This was also the solution for our connection issue with airwave 8.0.10

 

You also need to install LIS 4.0 to get the correct integration service otherwise Hyperv sees centos 6.6 using integration services for centos  5.1

Search Airheads
Showing results for 
Search instead for 
Did you mean: 
Is this a frequent problem?

Request an official Aruba knowledge base article to be written by our experts.