Monitoring, Management & Location Tracking

Do I need to upgrade to CentOS 5.3? If so, how do I upgrade?

AWMS 6.3 and above will no longer run on CentOS 4. If your AWMS server is running on CentOS 4 you will need to upgrade to CentOS 5 in order to upgrade to AWMS 6.3 and above. Using the AWMS 6.3 ISO you can upgrade the OS and your AWMS server in the same process, however...

YOUR AWMS SERVER MUST BE AT VERSION 6.2 IN ORDER TO USE THE AWMS 6.3 ISO TO UPGRADE THE OS. 

The following decision tree will help you navigate the upgrade process...


1) Are you already running on CentOS 5?


If no, go to 2) below. Don't know? See the instructions after the next paragraph.

If yes, you are already running on CentOS 5, YOU DO NOT NEED TO UPGRADE THE OS. You can upgrade your AWMS server code using the normal upgrade procedure. If you have not recently received an email with instructions on how to do that, please contact AirWave Support and they will send it to you. 

[Note: If you are currently running on CentOS 5.0, you will not be able to use the 6.3 ISO to upgrade to CentOS 5.3; the upgrade does not work. This will be fixed in a future version.]

To see what version of CentOS you're running on, do one of the following:

From the WebUI: 
Go to the Home > License page and look for OS in the System Overview section.

From the AMP command line run the following command:
# cat /etc/redhat-release

Example:
[root@amp ~]# cat /etc/redhat-release 
CentOS release 4.3 (Final)


2) Ok, you're running on CentOS 4. You need to upgrade the OS. Is your AWMS server at version 6.2?


(Not sure what version you're on? Check the Home > General page.)

If no, you will need to upgrade to 6.2 first before continuing with the upgrade to CentOS 5.3 and AWMS 6.3. You can upgrade to 6.2 using the normal upgrade procedure. If you have not recently received an email with instructions on how to do that, please contact AirWave Support and they will send it to you. If you are on a version prior to 6.0, please refer to the Knowledge Base article: 

Multi-step upgrade via interim version
http://kb.airwave.com/?sid=50140000000Mf7D


If yes, you're on 6.2, you're ready to upgrade to CentOS 5.3 / AWMS 6.3 using the AWMS 6.3 ISO. For detailed instructions please refer to the following Knowledge Base article:

AirWave CentOS 4 to 5.3 Upgrade Using_AMP 6.3 ISO
http://kb.airwave.com/?sid=50140000000MjFE

Version history
Revision #:
1 of 1
Last update:
‎06-10-2014 08:18 PM
Updated by:
 
Labels (1)
Contributors
Search Airheads
Showing results for 
Search instead for 
Did you mean: 
Is this a frequent problem?

Request an official Aruba knowledge base article to be written by our experts.