Monitoring, Management & Location Tracking

IGC Policy version not changing, when doing IAP firmware upgrade from Airwave


I did an IAP firmware upgrade from to and see that IGC policy version shows mismatch as shown below:



IGC page still shows as 4.2.3:



Upon checking the /var/log/igc.log, see the below error:


2016-10-21 13:58:36,757 ERROR Config verify
java.lang.Exception: Cannot compare policies from different models desired[] actual[]
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at com.airwave.core.AbstractService._work(
        at com.airwave.core.AbstractService.submit(
        at Source)
2016-10-21 13:58:36,758 INFO  Message sending:
{"command":"audit_result_update","ap_id":14,"audit_status":"Version Mismatched"}

2016-10-21 13:58:42,809 INFO  Core[1] Received message with type: update

2016-10-21 13:58:42,811 INFO  Group change type[update] for table[ap]
2016-10-21 13:58:55,633 INFO  Core[1] Received message with type: config








After the IAP Firmware upgrade from Airwave, We will need to give it about 15-20 minutes for the policy migration to happen. It will automatically upgrade and fix the version mismatches.

and will show up as 4.2.4.

Note: Please do not go ahead and do the policy migration manually from the IGC --> Airwave settings page, with in 20 minutes, unless you are doing a Policy version downgrade.

Version history
Revision #:
2 of 2
Last update:
‎03-29-2017 04:05 AM
Updated by:
Labels (1)
Search Airheads
Showing results for 
Search instead for 
Did you mean: