Monitoring, Management & Location Tracking

Installing AMP on existing RHEL/CentOS 4 or 5 for versions AMP 6.2.3 and before

The normal AMP installation includes the CentOS 5 Operating System. 

This document describes how to install the AirWave Management Platform on Red Hat Enterprise Linux 4 and 5, and also applies to installing AMP on a standalone version of CentOS 4 or 5. The customer is responsible for purchasing a copy of Red Hat Enterprise Linux or downloading CentOS for free from http://www.centos.org.

**Note**
AMP versions prior to 6.3 do not work on RHEL 5.3
If you'd like to run RHEL 5.3, please see the following article:
http://kb.airwave.com/?sid=50140000000MjCt

**Note2**
AMP versions prior to 6.3 are bundled with CentOS 4 or 4.3. AMP versions after the initial 6.3 release are bundled with CentOS 5 or 5.2. To verify your OS version, you can do:
# cat /etc/redhat-release


1) Copy the list of rpms (from a clean install of AMP 5.2 on Cent4) to the AMP being installed (eg. /var/airwave/custom/amp52.rpms.txt). This list is available today athttp://www.airwave.com/amp52.rpms.txt.

2) Use xargs to pipe that list to up2date

cat /var/airwave/custom/amp52.rpms.txt | xargs -i up2date {}

3) Disable selinux

Using nano or another text editor, open /etc/selinux/config and set

SELINUX=disabled

At this point, a reboot is recommended.

4) Download and unpack the AMP software:

wget --http-user='<username>' --http-passwd='<password>' http://www.airwave.com/download/AMP-5.2.3-cvs.tar.gz -O /root/AMP-5.2.3-cvs.tar.gz 
tar -zxvf /root/AMP-5.2.3-cvs.tar.gz -C /root 

5) Run the amp_install script (/root/svn/mercury/install/amp-install). You may see some errors during this step, and you can ignore them.

6) Run the upgrade_postres script (/root/svn/mercury/src/upgrade_postgres)

7) Remove/reinstall mod_perl

rpm -e mod_perl

rpm -Uvh --force /root/svn/mercury/src/rpms/CentOS-4.2/mod_perl2/mod_perl-2.0.1-1.fc4.i386.rpm
rpm -Uvh --force --noscripts?/root/svn/mercury/src/rpms//*libapreq2*-2.06-2.i386.rpm;

8) Do a make:

root; make

----------------

Some Known Gotchas:

Some distributions include Apache modules which are not compatible with the AMP. To work around this you can simply delete their config files. The ones we've seen in the past have been:

/etc/httpd/conf.d/python.conf
/etc/httpd/conf.d/php.conf

After those are deleted, we recommend that you run a make ("root; make").

Version History
Revision #:
1 of 1
Last update:
‎06-10-2014 03:14 PM
Updated by:
 
Labels (1)
Contributors
Search Airheads
Showing results for 
Search instead for 
Did you mean: 
Is this a frequent problem?

Request an official Aruba knowledge base article to be written by our experts.