Unable to fetch switch configuration

Aruba Employee
Problem:

Unable to fetch switch configuration.

 

HPE switch 3810, version 16.02



Diagnostics:

After adding the HP switch 3810 the configuration state in Airwave will show as error even though we have the SSH timeout set to 120 and updated the right SSH credentials.

1.  From group -> template page we will see the following message that No template is available,


2. We can validate if there is any timeout from System -> event log for that specific device

event log when trying to fetch template

Thu Aug 11 04:42:36 2016 Configuration status changed to 'Telnet/SSH Error: Could not fetch config file; command timed-out' System
Thu Aug 11 04:42:36 2016 Configuration status changed to 'No matching template could be found for this device. See the templates page.' System
Thu Aug 11 04:42:36 2016 Status changed to 'Error fetching existing configuration' System
Thu Aug 11 04:42:36 2016 Configuration verification: failed to read configuration from device System
Thu Aug 11 04:48:00 2016 Status changed to 'OK' System
Thu Aug 11 09:01:18 2016 Telnet/SSH Error: command timed-out admin
Thu Aug 11 09:03:20 2016 Telnet/SSH Error: command timed-out admin

3. We can validate the switch configuration:

Here is the issue after validating the configuration found that the banner was causing this issue since the switch is sending the CLI string in two buffers. First buffer comes with banner and the second buffer comes with password prompt. This is because of using  ‘#’ sign in the banner configuration. If we use a different sign for banner in switch configuration the password-prompt comes in one buffer.



Solution

In order to resolve the issue we need to remove the '#' sign configuration from the switch and replace it with any other sign egs:- '*','+',"&' etc.

Version history
Revision #:
2 of 2
Last update:
‎03-10-2017 09:25 AM
Updated by:
 
Labels (1)
Contributors
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: