Monitoring, Management & Location Tracking

Upgrade error: package y (which is newer than x) is already installed

Sometimes, upgrades to AWMS 6.2.3 will fail with messages like this:

package openldap-2.3.43-3.el5.i386 (which is newer than openldap-2.3.27-8.el5_2.4.i386) is already installed
make[4]: *** [security_patches] Error 2
make[4]: Leaving directory `/root/svn/mercury/src/rpms/CentOS-5.0'

This is fairly easy to work around by adding one line to one file in the AWMS. The following instructions describe using nano to fix the problem (you could also use vi or other text editors): 

1. Open the file in nano:

# nano /root/svn/mercury/src/rpms/install_rpm

2. Change this:

my ($rpmcheck, $rpminstall, @options) = @ARGV;
my $options = join ' ', @options;

to this:

my ($rpmcheck, $rpminstall, @options) = @ARGV;
push (@options, '--oldpackage');
my $options = join ' ', @options;

and save the file with Ctrl + x.

3. Run make:

# root; make

--------------------

Important Note: Future AWMS versions may fail in the same way, and it's very likely that this workaround will work in those cases too. If you run into this, you're welcome to email AirWave support so that we can verify this for you.

Version history
Revision #:
1 of 1
Last update:
‎06-10-2014 08:08 PM
Updated by:
 
Contributors
Search Airheads
Showing results for 
Search instead for 
Did you mean: 
Is this a frequent problem?

Request an official Aruba knowledge base article to be written by our experts.