Monitoring, Management & Location Tracking

Using a standalone backend to vacuum database "postgres"

Aruba Employee

-- SYMPTOM -- 

AMP is stuck in nightly maintenance mode. The log file (/var/cron_stopped_maintenance) shows a error such as the following: 

DBI connect('dbname=airwave','airwave',...) failed: FATAL: database is not accepting comm 
ands to avoid wraparound data loss in database "postgres" 
HINT: Stop the postmaster and use a standalone backend to vacuum database "postgres". 
at /usr/local/airwave/lib/perl/Mercury/Utility/SQL.pm line 90 
at /usr/local/airwave/lib/perl/Mercury/Utility/SQL.pm line 97 
Mercury::Utility::SQL::get_new_dbh('Mercury::Utility::SQL', 'undef', 'undef', 'und 
ef') called at /usr/local/airwave/lib/perl/Mercury/Utility/SQL.pm line 75 
Mercury::Utility::SQL::connect_to_db('Mercury::Utility::SQL') called at /usr/local 
/airwave/lib/perl/Mercury/DB/Q.pm line 20 
Mercury::DB::Q::init('Mercury::DB::Q=HASH(0x8593a88)') called at /usr/local/airwav 
e/lib/perl/Mercury/Base.pm line 46 
Mercury::Base::new_from_hashref('Mercury::DB::Q', 'Mercury::DB::Q=HASH(0x8593a88)' 
) called at /usr/local/airwave/lib/perl/Mercury/Base.pm line 21 
Mercury::Base::new('Mercury::DB::Q') called at /usr/local/airwave/bin/vacuum_amp l 
ine 28 
------------- 

-- SOLUTION -- 

1. Disable AMP 

# disable_amp 

2. Make sure postgres service is stopped 

# service postgresql stop 

3. Enter the postgres standalone backend 

# su postgres -c "postgres -D /var/lib/pgsql/data postgres" 

4. Vacuum the database 

backend> vacuum full analyze 

5. Exit the backend using ctrl-d (the control key plus the d key) 

6. Enable AMP 

# enable_amp

Version history
Revision #:
1 of 1
Last update:
‎06-09-2014 09:46 AM
Updated by:
 
Labels (1)
Contributors
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: 
Is this a frequent problem?

Request an official Aruba knowledge base article to be written by our experts.