Network Management

Reply
Contributor I

AirWave 8.2.3 won't talk to 172.17.0.0/16 addresses.

Ran into a bit of an issue today with upgrading to AirWave 8.2.3.

Seems the docker service was added in with the default network bridge.

 

The default bridge is 172.17.0.0/16 and is connected so all traffic going to 172.17.0.0-172.17.255.255 will go to the docker0 interface rather than eth0. 

 

Waiting to hear back from TAC, but using the Docker documentation this seems to work. 

https://docs.docker.com/v1.7/articles/networking/#docker0 

 

Login as root on the console/ssh:

Commands:

Stop the service

  • service docker stop

Bring the interface down

  • ip link set dev docker0 down

Delete the interface

  • brctl delbr docker0

Modify the configuration to use the new IP address

  • vi /etc/sysconfig/docker
  • add: --bip=x.x.x.x/xx to the other_args=”” line so it looks like this now:
    other_args="--bip=10.1.1.1/24"

Start the service

  • service docker start

ifconfig to confirm docker0 has been changed.

 

 

Aruba Employee

Re: AirWave 8.2.3 won't talk to 172.17.0.0/16 addresses.

Would you mind sharing the TAC case / ticket number?

Contributor I

Re: AirWave 8.2.3 won't talk to 172.17.0.0/16 addresses.

5316172332

Aruba Employee

Re: AirWave 8.2.3 won't talk to 172.17.0.0/16 addresses.

Here is what our engineering team came back with:

 

To delete the interface, we can execute the below commands:

 

[root@localhost mercury]# sudo ip link delete docker0 type bridge

[root@localhost mercury]# service network restart

 

To change the IP Address of the docker interface, we can execute the below commands:

 

[root@localhost mercury]# ip addr add 127.0.0.2/16 dev docker0

[root@localhost mercury]# service network restart

 

Let us know if this works or if you need more assistance.  

Contributor I

Re: AirWave 8.2.3 won't talk to 172.17.0.0/16 addresses.

Looks like an upgrade to 8.2.3.1 restores the configuration.

 

From the CLI to disable the service from start up.

SSH in as root, and run the following commands:

chkconfig docker off
chkconfig docker --del

 

To restore:

chkconfig docker --add

chkconfig docker off 2,3,4,5

 

 

Contributor I

Re: AirWave 8.2.3 won't talk to 172.17.0.0/16 addresses.

Just a heads up if this hit you it looks like HPE did the same thing for ClearPass with 6.6.7

 

HPE didn't changing this to something more approperate like a 169 address and then allow us to configure the docker bridge, or use a smaller netmask to reduce the blast radius.

 

I'm sure we will need all 65,534 address to run ClearPass Exchange, or AirWave Glass. At least it was in the release notes for ClearPass.  

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: