Network Management


Re: AirWave 8.2.4 NO CLI



Any news about include vmware tools support ? because it is complicated to ask to TAC for each upgrade of AirWave (when there is a Kernel Update !)

ACMP 6.4 / ACMX #107 / ACCP 6.5
Contributor I

Re: AirWave 8.2.4 NO CLI

In the VMware tools note, also request LIS for Hyper-V.

Re: AirWave 8.2.4 NO CLI

So, today I opened yet another TAC case for 5 new issues that we are facing in light of this horrible decision.


Let me know what Arubas though on these are:


1. We need to add more routes to the Airwave server. We are not able to do that when the root access was removed. 

2. We are unable to add additional network interfaces to the machine. Was easy to do before, now it is a problem.

3. How do we install the certificate and generate a Certificate signing request? This is for the web interface.

4. When the upgrade was made to, backups stopped running. They stopped completely. We previously used a bash script putting the files on an ftp server after backup was done.


5. Still, SCP file uploading/downloading does not work. Yes, TAC has looked into this has has no solution. Tried linux server, TAC recommended ones etc. Nothing works. Works with other clients/services. Not Ariwave

Occasional Contributor I

Re: AirWave 8.2.4 NO CLI

I have one mory story, too.

Tried to configure Mail in 8.2.4  Thank God, i still have the CLI. :-)

Mails didn't arrive our exchange server.  So i wrote the Mail Relay in the, restarted postfix and it works.

i figured out, that configuring mail is just working if postfix is stopped. So i stopped and deactivated the service, now everything is fine.

Impossible, to repair this without CLI.

And still there the question, why is postfix running, when it is a problem for Airwave?


New Contributor

Re: AirWave 8.2.4 NO CLI

after changing the ssh key on the server uploads to airwave will fail. because of no cli it is not possible to fix this.


Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that the RSA host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
Please contact your system administrator.
Add correct host key in /root/.ssh/known_hosts to get rid of this message.
Offending key in /root/.ssh/known_hosts:1
Password authentication is disabled to avoid man-in-the-middle attacks.
Keyboard-interactive authentication is disabled to avoid man-in-the-middle attacks.
Permission denied (publickey,gssapi-with-mic,password).
Couldn't connect to <ip>: unable to establish master SSH connection: bad password or master process exited unexpectedly
Hit enter to continue, 's' to show output, 'r' to show return code.


Occasional Contributor II

Re: AirWave 8.2.4 NO CLI

Just curious if the Clarity VM is going to get the no root access treatment as well?

Regular Contributor I

Re: AirWave 8.2.4 NO CLI

+1 for DB access


I have often used direct access to the postgres database on large sites to do detailed analysis & reporting. 



Regular Contributor I

Re: AirWave 8.2.4 NO CLI

Also changing timezone. 


The 8.0.11 -> 8.2.4 upgrade reset the timezone to PDT.


No way to change it.




Re: AirWave 8.2.4 NO CLI

Timezone option will be included in the next release.  It will appear under the Advanced sub-menu:


1 Restart Application
2 Reboot System
3 Configure Network Settings
4 Set Hostname
5 Set Timezone
6 Shutdown System (halt)
b >> Back

Rob Gin
Senior QA Engineer - Network Services
Aruba Networks, a Hewlett Packard Enterprise Company
Occasional Contributor I

Re: AirWave 8.2.4 NO CLI

We spent a considerable amount of time troubleshooting SNMP after installing


When it is first started the CLI root access is available. We did some successful 'sw' commands from the controller. But no amount of copying and pasting into the web interface would allow the SNMP functions to work. We saw an old post that suggested rebooting the system and it would "fix" issues from first starting an .ova file. So we attempted it, and it was still broke.

However, after reboot we were unable to do the 'sw' command because we did not have root access anymore.


In a way the reboot did "fix" the problem, because it allowed the Web interface to finally "accept" the data we were pasting into it.


Now I just need to get remote backups working. scp is usually easier than this, because you get to see the output of the command or use -v for verbose.


BTW, your CLI Menu sucks. It should not have made it out of beta. Call up some HPE/Aruba Procurve CLI Menu designers and get a few pointers.

Search Airheads
Showing results for 
Search instead for 
Did you mean: