Network Management

Reply
Occasional Contributor I
Posts: 5
Registered: ‎10-01-2013

Airwave 7.7.11 Web GUI not displaying after restore

Not sure if this is the right board for this but here it goes.

 

Just recently installed Airwave 7.7.11 on a new vm.  After the install I was able to access the web gui and install the license.  I was able to login with no problems.  I then restored airwave with a backup from my soon to be retired server.  After the restore, I am no longer able to login.

 

I've tried amp_enable but that didn't seem to work.

 

Any ideas?

 

Occasional Contributor I
Posts: 5
Registered: ‎10-01-2013

Re: Airwave 7.7.11 Web GUI not displaying after restore

Took a look at the erro_log.2014-05-19.  Maybe this will help?

 

[root@itdsrvairw00 httpd]# tail error_log.2014-05-19
[Mon May 19 10:47:32 2014] [error] Can't load Perl file: /etc/httpd/conf/bootstrap.pl for server itdsrvairw00.utep.edu:0, exiting...
[Mon May 19 10:47:45 2014] bootstrap.pl(31081): Starting...
[Mon May 19 10:47:45 2014] bootstrap.pl(31081): Not the last run yet (PPID: 31080)
[Mon May 19 10:49:06 2014] bootstrap.pl(31089): Starting...
[Mon May 19 10:50:36 2014] bootstrap.pl(31089): Last apache startup (PPID: 1)
[Mon May 19 10:50:36 2014] bootstrap.pl(31089): Preloading perl code...
[Mon May 19 10:53:21 2014] [error] ERROR: column t1.mc_global does not exist\nLINE 1: ...est_lifetime_duration_text,t1.allow_authorize_aps,t1.mc_glob...\n ^: select t1.sponsor_guest_lifetime_duration_text,t1.allow_authorize_aps,t1.mc_global,t1.visualrf,t1.guest_user_enabled,t1.id,t1.helpdesk,t1.sponsor_guest_lifetime_duration,t1.rapids,t1.sponsor_allow_sponsor_name_change,t1.flash_enabled,t1.allow_reboot_device,t1.enabled,t1.name,t1.sponsor_custom_message,t1.helpdesk_only,t1.sponsor_allow_no_expiration,t1.aruba_controller_role,t1.allow_disable_timeout,t1.access_level from role t1 where t1.access_level = ? and t1.enabled = ? ORDER BY t1.id NULLS LAST limit 1 (admin,1) at /usr/local/airwave/lib/perl/Mercury/DB/RoseTableRow.pm line 1188\n\tMercury::DB::RoseTableRow::get_all_with_args('Mercury::DB::Role', 'where', 'HASH(0x7faafc233b68)', 'order_by', 'id', 'limit', 1) called at /usr/local/airwave/lib/perl/Mercury/DB/Role.pm line 195\n\tMercury::DB::Role::get_admin_role('Mercury::DB::Role') called at /usr/local/airwave/lib/perl/Mercury/FakeRequest.pm line 40\n\tMercury::FakeRequest::new('Mercury::FakeRequest') called at /usr/local/airwave/lib/perl/Mercury/Handler/ConfirmMapper.pm line 493\n\tMercury::Handler::ConfirmMapper::fetch_map('Mercury::Handler::ConfirmMapper') called at /opt/airwave/lib/perl5/5.10.1/Memoize.pm line 247\n\tMemoize::_memoizer('CODE(0x7faaf33775c0)', 'Mercury::Handler::ConfirmMapper') called at (eval 56307) line 1\n\tMemoize::__ANON__('Mercury::Handler::ConfirmMapper') called at /usr/local/airwave/lib/perl/Mercury/Preload.pm line 77\n\trequire Mercury/Preload.pm called at (eval 28794) line 2\n\tMercury::Utility::BEGIN() called at /usr/local/airwave/lib/perl/Mercury/Preload.pm line 0\n\teval {...} called at /usr/local/airwave/lib/perl/Mercury/Preload.pm line 0\n\teval 'use Mercury::Preload ()\n;' called at /usr/local/airwave/lib/perl/Mercury/Utility.pm line 37\n\tMercury::Utility::dynamic_use('Mercury::Preload') called at /etc/httpd/conf/bootstrap.pl line 56\n\trequire /etc/httpd/conf/bootstrap.pl called at (eval 2) line 1\n\teval 'require qCompilation failed in require at (eval 28794) line 2, <DATA> line 558.\nBEGIN failed--compilation aborted at (eval 28794) line 2, <DATA> line 558.\nCompilation failed in require at (eval 2) line 1, <DATA> line 558.\n
[Mon May 19 10:53:21 2014] [error] Can't load Perl file: /etc/httpd/conf/bootstrap.pl for server itdsrvairw00.utep.edu:0, exiting...
[Mon May 19 10:53:43 2014] bootstrap.pl(31438): Starting...
[Mon May 19 10:53:43 2014] bootstrap.pl(31438): Not the last run yet (PPID: 31437)

Occasional Contributor I
Posts: 5
Registered: ‎10-01-2013

Re: Airwave 7.7.11 Web GUI not displaying after restore

[ Edited ]

Verified the restore...seems to be ok.   Still no web access.

 

[root@itdsrvairw00 httpd]# dbc 'select count(*) from ap;'
count
-------
754
(1 row)

 

 

 

nmap of the server shows the following:  No port 80 or 443....

 

 

Nmap scan report for itdsrvairw00.xxxx (129.108.0.xxx)
Host is up (0.0045s latency).
Not shown: 998 closed ports
PORT STATE SERVICE
22/tcp open ssh
111/tcp open rpcbind

 

 

 

Any help would be appreciated.

 

 

Aruba
Posts: 1,377
Registered: ‎12-12-2011

Re: Airwave 7.7.11 Web GUI not displaying after restore

Please open a support case for this...they can assist and resolve

Seth R. Fiermonti
Consulting Systems Engineer - ACCX, ACDX, ACMX
Email: seth@hpe.com
-----
If you found my post helpful, please give kudos
MVP
Posts: 1,434
Registered: ‎10-25-2011

Re: Airwave 7.7.11 Web GUI not displaying after restore

you may just have to recompile with "root; make"

But yes, Open a support case first.
Pasquale Monardo | Senior Network Solutions Consultant
ACDX #420 | ACMP
[If you found my post helpful, please give kudos!]
Search Airheads
Showing results for 
Search instead for 
Did you mean: