Network Management

Reply
Occasional Contributor II

Airwave RAPIDS event clock is wrong

Hi

i have a strange issue.

running latest 8.2.3.1 AW, using vmware appliance.

hwclock is synced. cli shell date shows correct time. time-setup is set to UTC (we collect logs in UTC). NTP is configured for AW (although i'm not sure whether it can acually sync, there are no visible test options).
AW event logs show correct UTC time, but rapids is still living in its EDT time.

restarted AMP service (after clock sync), didn't help.

any ideas?

Aruba Employee

Re: Airwave RAPIDS event clock is wrong

Hi Anders,

 

In AMP Setup > General>Dipsplay section set Timezone for UI Charts/Tables to UTC ,if it set to Browser local and check the status.

 

1.PNG

 

 

Regards,

Pavan

If my post addresses your query , give kudos:)

 

Regards,

Pavan

Aruba Employee

Re: Airwave RAPIDS event clock is wrong

Occasional Contributor II

Re: Airwave RAPIDS event clock is wrong

already have Timezone for UI charts on UTC.

this affected home page/AP-devices/Connected clients etc visible charts but for some pequliar reason not RAPIDS->IDS events.

 

btw, just found out that syslogs & traps and reports are also showing time in EDT timezone.

 

for example, with UTC as AMP Setup-> General and System Defaults on Home-User Info. these events happened after any changes.

rapids.jpg

 

AW internal event log though (and usage/clients charts and tables) shows correct time.

Aruba Employee

Re: Airwave RAPIDS event clock is wrong

Hi ,

 

Could you send below command output

 

#date

#hwclock

# service ntpd status
-If you're utilizing NTP, then this will check to make sure that the service is running.
# ntpdate -u <ipaddr of ntp>
-This is a related NTP query which shows the offset jitter of the NTP server.

 

Regards,

Pavan

Occasional Contributor II

Re: Airwave RAPIDS event clock is wrong

[****@amper mercury]# date
Wed May 17 12:21:19 UTC 2017
[****@amper mercury]# hwclock
Wed 17 May 2017 12:21:22 PM UTC  -0.719101 seconds
[****@amper mercury]# service ntpd status
ntpd (pid  2054) is running...
[****@amper mercury]# ntpdate -u 194.126.115.41
17 May 12:21:28 ntpdate[7851]: adjust time server 194.126.115.41 offset -0.000115 sec

output from SSH to AW server

 

noting that i changed time-zone (using ./time-setup) some time after initial installation (although i've restarted AW afterwards).

Aruba Employee

Re: Airwave RAPIDS event clock is wrong

Hi,

 

Does contoller/IAP is also in UTC timezone?

 

Regards,

Pavan

Occasional Contributor II

Re: Airwave RAPIDS event clock is wrong

yes, timezone for groups (i'm using instant config mode) is UTC.

it seems that anything that is predefined report related (including RAPIDS reports) show time in  EDT, but i see no way to change it.

all predefined reports (network usage, rf health etc) show their generation time in EDT. All reports under Definitions (where are predefined reports) are using EDT time.

i'm pretty sure i haven't put EDT anywhere, as i'm living in europe (actual timezone is EET or eastern european time).

 

for example, i can make a new generated report under Reports->Definitions, but for some reason it shows EDT as scheduling time option and no ways to change it.report.jpg

i just took the screenshot, so the actual time when taken screenshot was 16:11 UTC. Why is shows Current Local Time in EDT is beyond me.

it was the same with previous 8.2.2.1 (just recently upgraded to 8.2.3.1). 

 

even more strange: events under RAPIDS->Audit Log show UTC time (i think they are event logs), but events under RAPIDS->Events show EDT time.

Aruba Employee

Re: Airwave RAPIDS event clock is wrong

May I know how did you set the timezone as UTC in Airwave? Could you map your timezone to localtime

 

sampe example below where we are mapping shanghai to localtime.

 

rm -rf /etc/localtime
ln -s /usr/share/zoneinfo/Asia/Shanghai /etc/localtime

 Regards,

Pavan

Occasional Contributor II

Re: Airwave RAPIDS event clock is wrong

did what you provided, but no difference.

 

IIRC, there wasn't any time setup while OVA appliance install, just NTP configuration (and it's correctly showing under AW->AMP setup->General).
after that i saw that event log times did not match, but graphs were okay (default is local browser default i guess).

so i manually updated timezone, like here:
https://community.arubanetworks.com/t5/Network-Management/How-to-Set-Airwave-Clock/m-p/293995

 

i also synched system clock using NTP and then synced hwclock  with --systohc variable.
after that i restarted AW service.

 

currently

amper install]# ./time-setup
------------------------ Date and Time Configuration ---------------------
         Current Time: Wed May 17 19:08:04 UTC 2017

         1)  Change Date and Time
         2)  Change Time Zone

         0)  Finish

so system clock itself is fine and also AW time for logging is fine. It's something deeper in AW generated reports, which doesn't want to take timezone into account and use instead some sort of default timezone (generated while installation i guess or come by default).

 

i haven't rebooted server itself (it's a production server after all, with over 100 connected AP-s), but i doubt it'll help

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: